Battery works great, indicator reads incorrect


The battery charges normally and lasts several hours, but the indicator stops at 100%

Windows 10 battery preview displays:
Currently no battery notifications

Any help on fixing this would be greatly appreciated.

1 Like

Hi, I have the same Problem with my battery

Describe your problem to the

Does anyone read emails there ?

Same here… it is not an isolated issue then. Also in the CHUWI Backers’ group on Facebook you see quite a few people have the same problem

Contact Neither in the Facebook backer group nor here they can give you a technical solution.

Try with a few cycles of complete discharge/complete recharge. Make sure the machine does not sleep and the screen does not become inactive when unattended (power and sleep control panels), and that the machine only hibernates when under 1% battery (advanced power configuration). When discharged press the power button a few times and let it die until it does not wake up anymore. Full recharge. Repeat until the indicator starts working again.

It worked for me. It is a sign of a buggy BMS (I.e. cheap battery microcontroller) and/or bad battery support in the OS (Windows). Never heard of these problems with Apple laptops for 25 years. Apparently it is common on Windows machines. This is the last non-apple laptop I buy, quality has a price and I am happy I can afford it.

Thanks for the information, EC is a problem so I await the service’s response.

please don’t discuss about apple this is not a forum, for me apple is an expensive useless typewriter that I don’t need.

1 Like

Dear Pawel, give battery recalibration a shot. It worked for me. It required a couple of rounds, but the battery meter started working properly. There are other problems with the EC on the MiniBook - for instance my MiniBook wakes up from sleep sometimes (one time out of twenty, roughly) with a blank unresponsive screen. I must force a hard reboot.

As for Apple being “an expensive useless typewriter” this only proves that you have no clue whatsoever of computing, the research behind it, including UI and UX, and that you are probably a “wintel” zealot (or maybe, even worse, a linux zealot). It seems that I have touched an inferiority complex nerve, but last time I have performed a battery calibration was a few decades ago – whereas battery problems and wake-up-from-sleep-with-a-blank-unresponsive-screen plague the whole PC world. Just to make one example.

If you do not trust the word of a (sometimes infantile, I admit) CPU architecture architect (yeah, it is a bit redundant) and lead cryptographer at one of the world’s largest semiconductor designers, feel free not to try the discharge/recharge cycles. After all, they may not work on your machines – there is amazing variability in the HW problems people are experiencing with this little (and beautiful) machine, the cause of your trouble may as well be different.

Good advice, even though I did give a potential technical solution :wink:

Dear moceniego,
I get the impression you misunderstood me. I wrote that only for me is useless because of the work I do and the software I need. I do not absolutely think that the rotten apple has poor technology, I just think it is expensive for me. let’s end the discussion (this is not the topic).

I am just following the procedure you described, I will write if the indicator returns to normal - I hope :wink:

problem solved:

  1. EC installation (note, because there are different versions, it is best to contact the service).
  2. Discharge to the end.
  3. Fully charge.

it worked, the indicator shows

1 Like

Guys try this:

Open cmd using Administrator priviledges
Type: powercfg -setdcvalueindex SCHEME_CURRENT SUB_BATTERY BATACTIONCRIT 0
This changes Critical Battery action to nothing, that way battery is drained at 100%, otherwise minibook hibernates, shuts off etc at 5% battery level, can’t put less value than 5%