Miniboook Battery and also replacement not charging (solved)

Hello Chuwi Support

My Chuwi Minibook Y8100 only works with Power Supply. Battery not work. Then i bought a new battery from China but this one also does not work.
With both batteries the red charging light is blinking. And Windows 10 said Battery Full and Level is 255 Percent. Sometimes also said battery not detected. AIDA64 detect the battery. SN is 12345679… Strange…

So i tried many things. Replug Battery. Press Power for 30 Seconds. I also recharged the battery with an extern Lipo loader. After power on with connected Power supply and charged battery the chuwi boot and runs Windows 10 but did not charge the battery. Also run after remove power supply. Switching on without Power Supply does not work. (No BLUE LIGHT)

Also reinstall Windows 10 from Original Chuwi Image.

After reading all the posts and also flashing the bios nothing changed.

So i want to try reflashing the EC.

Please send me this file for 8100Y (Europe Version)

Someone any ideas?

Thank you very much

1 Like

Hello Harry,

I have bought a another NEW! Battery but the same Problem too,
Windows shows in the Taskbar the same like you wrote before,
255% Battery Power LEVEL! Or NO! Battery present.

NOW! I have another POWER-PLUG from APPLE! Tested with 65W,
And for the FIRST! Time I can see, that the Power-LED switch from red to blue,
Blinking every one or two second between these two colours, GREAT!!!

Tomorrow I will see, if the BATTERY! Is full charged or NOT! Now I’am going
SLEEPING! Good Night and bye, bye.


Joel Kind.

Hello CHUWI Support,

I have PROBLEMS! With your MiniBook 8 (m3-8100Y) WHY???

I DON’T know.

My Problems:

1.) After changing the Battery, it shows under Win10 (22H2) 19045.4355 latest
BUILD! In the taskbar 255% of Battery Power, not 100%, after unpluging the
Battery, waiting some Time, pluging again, after powering up, going into BIOS!
Just saving! And Reseting! The BIOS! Then the Minibook RESTARTS! After loging
Into Windows, in the Tasbar, the Battery shows 255% of Power (Battery), but the
NEXT! Time I start the Minibook, in the Tasbar! Windows shows, there is NO! Battery
FOUND! And in Windows SETTINGS! Too, only AC-PLUG! No Battery anymore there.

But at the FIRST! Time START! After unpluging the BATTERY! There was a BETTERY! Found
By Windows, why???

What is the PRBLEM!!!

And what I also SEE! Then the Minibook turnoff!!! Then I do something on it, but at a short or
Long Time, my other Computer, Tablets or Phones become a BREAK! In the WIFI! Connections, WHY!?! I don’t KNOW! “Strange!”, why???

I think, some “HUMAN!?” or what ever, must DO! Some mistakes with “your” MINIBOOK!
I don’t KNOW! What, but I think so.

Maybe I must FIND! Someone, who wants to HELP! Me, to FIX! It.

A PROFESSIONAL! Electronics, who KNOW! What is the Problem, just that SIMPLE!

For ME! I can NOT! Solve the PROBLEMS! With the Minibook, SORRY!

But it is NOT! My PROBLEM! Finish.

JESUS! Emanuel, the SON! (The MESSIAH!) Of the ALMIGHTY! God SAYS!!!

DO! NOT HARM! ANYONE! Love YOUR! Next, as You LOVE! Yourself, AMEN!!!

GOD! DO NOT! HARM! Anyone, YOU! Hear, understand!? THIS! Message!?

And the BEST! Very Best ADVICE! Just READ! the HOLY! Bible, then EVERYONE!
Can KNOW! How to LIVE! And how to get WISDOM! Just that SIMPLE! Finish, too.

The VERY! Last WARNING! Finish, EVER! Amen.

And Yes, JESUS! Is the LORD! Amen, END!!!1

Greetigs from GERMANY!

Joel kind
(Krasnica Stepanovic)

And YES! I’am JUST! A Human, too, nothing else.

I wrote THIS! Text on my other CHUWI MiniBook X that WORKS!
TILL! Now, with NO! Problems, GREAT!!!

On the MiniBook 8, I can NOT! Work, it get’s power OFF! Sometimes,
after a short or long TIME! Randomly! Why??? I don’t know.

And SORRY! For my ENGLISH! It is NOT! My HOME! Language,
JUST! From learning from SCHOOL as a CHILD!!! End.

AND! No, the Battery is NOT! Fully CHARGED! After I woke UP! Next DAY, “shit happens”.

@JoelKind I am sorry to hear you are having trouble with the computer. As it is an old model, i dont think its under warranty anymore. It seems hardware issues.
Would you want to pay the expenses for it? Probably you would need to send it to Hong Kong.


NO! Thanks, I will try to fixit by myself.

It is crafted by Human’s, me too, then

I can repair it, no Problem.

I believe in Jesus, what Do I not can DO!

Everything! Is for ME! Then POSSIBLE! With JESUS! Yes, for sure, Amen.

THANKS! Jesus, everyone can KNOW! This “secrect”, because
It is NO! Secret, just READ! The HOLY! Bible, just that Simple, FINISH! Amen.

But those who rule this World makes about JESUS! A secret, ME! Not ever.


Joel Kind
(Krasnica Stepanovic)

ok, then i hope you can solve it. We apologize.

Hello Joel
Had the same problem with an “original” battery from Alibaba. But this was not an original battery. Later i bought an minibook with broken display from ebay and then used this battery. and everything worked.
so i can confirm that ALL batteries from China Shops not working. You need the original chuwi battery.

The technical reason is that the original Chuwi Battery uses another controller chip inside the battery.

And all other replacement batteries from Alibaba and other use another not compatible controller chip. This controller board is located between the 2 battery packs inside the battery. The only for me known solution is to use the old controller board and replace the wrong (not compatible) board inside the new battery. Soldering and experience is required. Then press the power button from the chuwi minibook until the power LED flashes to reset the controller firmware. Then charge at least 8 hours. Thats all.

And please Joel stop to write about religion. This is a technical forum with people with many different religions. And we all try to help each other. So please stop. Personally you are hurting me. And stop with the writing an exclamation (!) after every 3rd word. And stop writing in BIG letters every 3rd word. This is very annoying and unfriendly.

This is the wrong place.
Thank you

Thank you Samira, for giving that info, im sure other users would appreciate.

I understand your Chuwi Minibook Y8100 isn’t detecting the battery even after replacing it. While I can’t provide the EC firmware here, Chuwi support can assist.

Contact Chuwi mentioning the blinking light, abnormal battery readings, and trying a new battery. They can advise on EC flashing and potentially provide the file.

Hello CHUWI-Support,

after change of Controller mini Board
Between the two Batteries my MiniBook charge NOW! The two NEW!
Batteries “I” have bought from China Market, GREAT!

But why? They SELL! For Chuwi Minibook Batteries that DON’T Work???

See the Pictures for more Details, maybe some Chuwi Ingenieur can make
A EC-Firmware that can WORK! With these other Batteries sold by other
Manufacturer, MAYBE!? I don’t know, what is the Problrem.

The FIRST! Battery was the ORIGINAL from Chuwi, but “dead”.

The second was from another Manufacturer, i don’t know the brand, but
just SEE! The mini-Controller Board, second Picture.

The third Battery was from Aolstcell, I did not “open” the Battery, to see
what Controller is build in, but you can See on the Picturer too, the Number,
Of the NEW! Third Battery, OK! Maybe YOU! Can find out, what Is wrong with
It, from Aolstcell it is BRAND! New, only a few weeks old, NEVER! Been charged,
Because of the known Problem, in Windows it is not recognized! The same Problem
As the second Battery.

PLEASE! Look after it, I THINK! It is the best for Yor Company too, isn’t it.

Now, I’am HAPPY! With my MiniBook.

The NEXT! I have tryed is a SSD from TOSHIBA RC100 with 128GB space,
But It was NOT! Recognized by Windows and not in the BIOS, and in the
Advanced Menu in NVME-Settings they is no Device recognized too.

Why? I don’t KNOW! maybe it is NOT! Compatible with the MiniBook.

PLEASE! Tell me too, what kind of SSD work with my Minibook, I have not
Found any Info about a SSD-Upgrade in the MANUAL of Chuwi, Sorry.

And the last “Problem” I have, is that the USB-C Charging Port have a Problem
By PLUGING! The Cable in, I must often turn in or out, and then I can
See, that it is connected and charging the Battery, I think, someone have
Disconnected The cable by feed, or something else, but with force, and because
Of that accident, the contact is not the best, I must search for it.

But this Problem is not easy to FIX! Because I must then solder a New USB-C
Port on the Mainboard, for me to “heavy”, only for a professional person.

That’s all, I hope someone can help my post, THX!


Joel Kind.

Thank you for informing about this
If you can send the link from where you bought the battery that would not work?

Also we always recommend to ask us if we have batteries in stock beefore buying from another store.

Hello CHUWI-Support,

Yes! I can LOOK! Here: (or this:) (This! WORKS!)

ORDERID: NLB20240130212057972310 from 31.01.2024

FIRST! Order of two Batteries, one for Microsoft Surface A50
And one for CHUWI MiniBook 8 was LOST! By DHL! Ok.

BUT! I don’t KNOW! Why? And who? STOLE! This two Batteries,
YES! Shit happens in THIS! World, but it is NOT! “My” Problem, OK!?

That’s ALL! I have to SAY! Finish.
Till until NOW! My MiniBook WORKS! Great, HAPPY! With it. :slight_smile:

Must ONLY! Try another SSD! To see if it works. Here in CHUWI-Forum
They have said, that NVME-SSD should work, but my NVME-SSD don’t work.

But I wil try other SSD too.

Joel Kind
(Krasnica Stepanovic)