Minibook dead on arrival - battery troubles

Happily and excitedly received the Minibook (8100y, EU version, 16/512 GB), unboxed it and after charging it overnight (I always first charge my new devices) tried to switch it on next morning.
Surprise: still dead. I recall the charging led being steady red all night, but at that time haven’t paid too much attention.
I connected the Minibook to the charger and able to boot it and configure Windows.
But device still not charging and indicating no battery available and 255% power (definitely from the charger)
Have sent an e-mail to Chloe, she very fast and efficiently answered suggesting me to reflash the EC and attached the download link for the new ones.
Full of hope, did it as instructed.
Same result.
Battery undetectable. Reboot device…same again…no battery.
I tried my luck entering the BIOS menu and, without changing anything) only FN+F4 (SAVE&EXIT) this time…voilá…I had the so desired battery icon in Windows bar and battery detected.
Full of trust and hope I let the device charging for several hours.
But when I tried to reboot it, again…no battery available…
Well, end of emotions…what to do know ? R&D of course…Started to read comments and threads on and on Chuwi Minibook supporter’s Facebook page.
Find out I was not alone.
In my sufferings but also in my hopes to getting the expected functionality of my brand new Minibook.
Also installed AIDA 64 helping me to get a clear view that the battery was not detectable.
Have found the hidden battery controller in the MANAGE DEVICES, it was indicating “all systems go” :thinking: :upside_down_face: :lying_face:, tried to disable and back enabled it but the same final outcome: no battery…
Since most of the comments and suggestions were indicating that disconnecting the battery helps solving the problem…I have crossed the Rubicon. Opened the gadget…yes…had to remove the tiny (warranty :frowning: sticker) to remove the last screw and as so precisely indicated on forum posts, I disconnected and connected again the battery.
Voilá again: now having battery. quite uncharged (6%) but now charging and charging LED flashing blue-red this time.
Also detected by AIDA 64 even with a strange serial number: 123456789 :+1: Feeling better now.
Don’t think I had won the battle…
Charging process stopped at 60%.
Reboot the gadget.
Charging process continues: 61%, 62%…well, me crossing fingers and hoping for the best.
Start Aida 64 again and everything seeming to go fine.
But for each 2% of battery charge, AIDA was indicating an additional 1% battery wear…
Well, not so good for now…Also the charging process stopped several times and was only able to continue it after rebooting the device.
When arrived at 80% charge level and 17% battery wear :anguished: I stopped.
Meaning I turned off the Minibook and let it connected to the charger.
At that time I noticed it was warm but not hot in the area of the battery. Somewhere around 40ºC.
Charging LED was flashing red-blue.
Hoping for a better faith and luck next day. I left the Minibook charging again overnight.
Next morning, as a child waiting to see what Santa left under the tree…found the Minibook with the charging LED steady red.
Disconnect it from the charger, boot it up and find the battery icon in the windows bar. That’s good news and again hope.
Charge level: 84% and battery wear indicated by AIDA64 at 18%…What a …you name it…
In less than 3 minutes of functioning, the device stops…battery drained from 84% (really… George ???) to, will figure it latter, 5% and gadget stops.
What to do now ?
Connect charger, flash again EC, reboot the device, (new element, on the CHUWI booting screen, get for the first time an orange warning BATTERY LOW).
Well, new inputs, new hopes.
Boot the device, seems everything goes well, indicated me battery level low (5%) but have it charging. Open AIDA64, indicating me same info and a battery wear of 0%, good news and again naive hopes…

Process ends at 6%. No way to go further. Charging LED stubbornly getting steady red instead of flashing red-blue.
What next ? Publish it on forum and FB and will wait for CHUWI support. Really feeling as “dead” as my device which was DEAD ON ARRIVAL and after trying to do all I know&could to resuscitate it, had to give up.
With an important travel in 6 days from now, when I was expecting to use the Minibook as a most needed tool.
Having to pay now extra money to send it back for repair (wouldn’t be quite ethically fair because I can’t skip I received it already dead…) and perhaps even CHUWI to tell me I voided the warranty…
Feeling hurt and bit deceived.
I need that tool. I’m a traveller and content creator for several social-media. I need a tool allowing me to travel light because I have plenty of other photo&video gear to carry. Still think this is the device I need. And still happy I have supported Chuwi and the project. And even being able to understand it might not be easy to create such device from scratch. Having a sort of not so happy thoughts for the gentleman or lady who put the sticker A2/CHUWI/QC on my device’s lid. Because this was not Quality Control…That device It should have not left the factory as it did.
Yes, I feel now unhappy also of having crossed the Rubicon when opening that lid, disconnecting and reconnecting the battery, but…what if…the device would have arrived as I think it should: 100% functional allowing me to focus on my creating, editing, photo video job and not to have to search and find ways to make it come to life.
Well, that’s my story and grim experience for now, still hoping to have, the soonest the better, that tool I believed (and believe in + need) when I ordered my CHUWI MINIBOOK.

You sir must be a highly acclaimed writer. What a story! The problem that you have described is a lot like the still-unresolved “plugged-in not charging” issue that have afflicted a few generations of laptops since 1990. Many have tried and the solutions are always episodic. It now appears a miscommunication between the battery and the BIOS/OS. The firmware in the battery is either outdated or corrupted, or both (in your case, possibly a corrupted firmware). Manufacturers are of course ultimately responsible; although it is not practical for them to recall every single battery. So DOA is an apt description. Hope you get the problem resolved soon.

Thank you Sir, your answer is crystal clear to me now and really appreciate your effort to help me.

Will see what feedback to receive from Chuwi Aftersale/Service and hope to get the problem sorted soon. Thanks again

:heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart::heart:︎ Good luck with that! =)

This trouble is really common on Chuwis. And like almost all chinese business factories they are unfair. When they have received the money they think the relationship is ended. Nothing is as false as this assumption.
I think that the quality of the batteries they use is very poor, furthermore i think they leave these batteries discharging under the damaging level, so they arrive damaged. At the first charge you will definitely kill it. Battery controller and related peripherals become crazy, nothing more, nothing less. No EC flashing, reboot, or anything like this will solve the problem. Only if the battery is in good condition, if not detected, it can be solved removing the peripheral and rebooting the minibook.

I’m curious - did you get it resolved?

Yes, Chuwi substituted or repaired my battery.

There are still two desgin flaws, the noisy fan and poor cooling, the minibook getting extremely hot when operating and the reduced autonomy of the device (2 - max 3 hours).

Should Chuwi be able to fix these flaws, an excellent product could arise.

The fan you can fix/replace yourself for approx 10 euro, if you can handle a soldering gun. The difference in noise is really a matter of day and night.

With the EC mod the fan also can be stopped when the Minibook is running idle, this saves also some noise.

Then, as a double bonus, you also can install Intel XTU to undervolt the cpu. This will lower the power consumpion, and therefore the heat of the cpu without losing any performance.

The EC mod and XTU will already be a nice improvement, and both can be done quite easy in a matter of minutes as it is only software. If you can change the fan as well (requires opening the laptop, requires soldering skills, requiring ESD safe workplace), then you will have a very very silent Minibook.

Many thanks Theo,

I very much appreciate your info, I’ll definitely will take the try.

Thanks again

Some time ago i was by the chuwi minibook. and yes, a was make full charge, but on second day when i was plugged charge to my pc i was in shock. The latop wasn’t charge.
I try different variants and charges. But result was the same.
After this i just turn off windows by power off, and change my power setting for defaults.
After this i was install all recomended updates from microsoft. And now my laptop work correctly.

I think the main problem for topic stater was OS.
First that i’m do in the same situation - i start from any live CD/USB flash drive (with ubuntu for example) and make a tests. Sorry, but windows isn’t good OS. So, maybe you spent your time but problem was not in hardware.
Check it please from another OS that you test will be correctly.
I think its very interesting for all of us.(chuwi owners)

Hi Kobzar,

as explained before, the problem was a faulty battery and Chuwi replaced it.

is this roblem perdisting? i think istart to see my Minibook switch itself off on 30ish ercent batteyr, i fea whether this is the same battery charging not to max problem or a faulty display of the laptopn current battery charge by windows (HW monitor app also display same charge as windows so that app doesnt help)

What will help is to ‘calibrate’ the battery.
In Windows disable all battery save functions. Then start a random video, put it on repeat and wait until the Minibook stops working because of an empty battery. Then start the Minibook (if there is any power left in the battery) and wait until it stops working due to a flat battery. If needed repeat untill the batttery is completely empty and the Minibook won’t switch on anymore.

Then connect the charger while the Minibook remains off and let it completely charge until the red charging LED becomes blue. (most cases this will take 3 hours or so) Optionaly you also can use a power meter between your wall socket and the charger to see how much power the charger is using (16 watt during charge, 0 watt when full, between 0 and 16 watt when almost full)

Once the Minibook is fuly charged you can press the power button. Leave the charger connected. Once Windows is started you can see that the battery is ‘100% and connected’. Then remove the charger. The battery should remain 100%, and should gradualy decrease to 5% in a few hours. (Windows shuts down at 5%)

My Minibook seems to have a good battery, but I also need to do this every now and then. Otherwise the batttery will remain for 45 minutes on 100%, and the minibook will stop working at 25%.

The maximum battery time I was able to get was approx 4:30 hours. (wifi/BT off, keyboard light off, screen darkest, 8100Y undervolted and repeating a 480p video.)