CHUWI Minibook (8100Y) Not Able to Power Up After First Charging

After received my MiniBook, I was able to power up and loaded with Windows 10. Then I left it connected with the USB Type-C charger overnight. The next morning it was not able to power up. With the charger connected to my MiniBook and power, the power indicator light is not light up.

Please contact with service@chuwi.com, friend.

Hi I had the same problem and had to open the minibook, unplug the battery, plug it in again and the had to press the power button, afterwards it started again. Than you can connect again the Charger and it works well

Count me in too. After using the minibook 8100 with the top notch 16go and 512 sddr without a worrie for almost a week , it wont charge and start anymore ( no led on also) I had weird readings of batery meter as many of us but After few charges cycles minibook shutted off when meter hit 10%. Always plug it with provided charger and didnt mess with the bios ever. I ll contact custumer support Indeed but i Guess they have more serious public health matters to deal with and that s perfectly understandable. I still Hope that in the end CHUWI will find a solution to this récurant problem. Thé Time it worked the minibook was an incredible mini device !!!

Mine works very well since November 2019. I did have problem powering it up on battery after letting it charge over night after receiving. The Minibook turned on as soon as I plugged in the charging cable and letting it charged a little while. It was then running fine until last week when I put the computer to sleep for a “few days” It appeared that the battery was discharged completely. Plugging the 45w charger (or even my Macbook Pro USB charger) did not help. I opened up the back cover and measured the battery voltage. The battery voltage was 0V (completely dead) Since I did not want to ship the computer back to Chuwi for service, I removed the battery and charged it outside using my RC multi-chemistry battery charger (charge slowly as nicad to bring the voltage up to 6.6+ vVolt then switch to 2s LiPo charging) Once the battery is more than half charged (charger puts 2000+ mA into the battery), I reinstalled the battery into the computer. I was able to turn on my Minibook after that. The charger is also working now.

I browsed the web for posts from people with battery problem on the Minibook and found that quite a few people had “dead battery” and were not able to charge their computer afterward.

I believe there is a problem with the design of the charging circuit on the Minibook. If the battery voltage is somehow drained down, the charging circuit refuses to kick in unless a fresh battery is installed.

I will not be putting mine to extended sleep anymore :slight_smile:

I have same situation. I put this to sleep for a few days and have no power situation after that.
Could you tell me the product name for your RC multi-chemistry battery charger?

I want to try this.

I just happen to have one because I fly remote control plane/helicopter. I think you charge it with a nicad/Nimh charger with 7.4v (6 cell) with a low current (250mA) and measure the voltage to make sure that it is at least 7 volt before plugging it back into the minibook and use the USB-C charger to charge it fully.

You can also buy a cheap 2s LiPo battery charger to charge it (the minibook battery is 2s LiPo) I think the trickiest part is to make a charging pins that are small enough to fit into the battery connector (black and red wires at the opposite end of the connector)

Thank you for your information. I got the another 8100Y-8GB and swap the battery. And Both Minibook worked fine.

hi, I was just wondering whether after you start being careful about it, have you ever face this problem again?