Chuwi Minibook doesn't work


I have a Minibook bought last year, it worked great till yesterday, when I plugged the charger to charge it then the computer turn off and when I tried to turn on again, the power led (blue) blink one time and nothing more happens.

I tried to charge it, and push the power button for a few seconds without any luck… Right now the computer doesn’t turn on and doesn’t charge, not even a status led is showing. When I plug the charger nothing happen I cant turn on the computer and I there is no charging led or any other.

I read in the forum that is possible to revive it disconnecting the battery and connecting again, I tried it without any luck…

Is there anything I can do?

Thanks a lot

I’ve got the same problem with my Minibook; it refuses to charge when the charger is connected when the device is off. But when the battery is completely flat/empty it can’t start, and due to that it won’t charge.So with an empty battery I’m screwed.

If there is a bit of energy left in the battery (enough to run the Minibook for 2 seconds), press the power button and after one second connect it to the charger.

If the battery is completely flat you need to put some charge it with an external charger. For this you need to disconnect the battery again and connect it through a 10 Ohm resistor to a 5V (usb) power supply while monitoring the battery-voltage with a volt meter. Or use a regulated power supply, or connect it to a li-ion charger.

When using a 10 Ohm resistor let it charge half an hour, or untill the battery reached 4.00 volt. Then reconnect the battery and close the minibook. Press the power button and direct afterwards connect the charger to the minibook and let it charge.

Sorry, I just read your message (Don’t know why I didn’t get an alert…)

It’s strange because my Minibook in the past charge even when it was shut down.

In your case, when you plugged the charger the led light turn on? In my case there is no signal of life at all.

Another question… I have a Lipo charger… How I can connect directly to the battery??

Thanks a lot!!

When the minibook is off and I connect it to the charger absolutely nothing happens; no light goes on, no current flows, nothing. (this is the case with multiple chargers).
Buw when I connect the charger while the minibook is on it will just charge as normal. When I shut down the minibook while charging it remains charging. But when I disconnect and reconnect the charger nothing happens.
My indicator LED is working as normal; red means charging, blue is fuly charged. When it’s not charging the led is off.

The Minibook battery could be connected to your li-po charger; li-ion and li-po used roughtly the same charging curve. Ensure you’re using a current in the range of 200-1000 mA. It might be that your charger won’t work if it can’t handle zero-volt cells (li-ion and li-po should ideally not be discharged below 2,5 volt)

Get two thin wires (like the individual wires in a UTP cable) strip of each wire both ends and stick these wires in the battery connector (obviousely unplug the battery first), and connect these wires to your li-po charger. If that won’t work (like: if your charger can’t handle a zero-volt cell) then use a low ohmic resistor (4 to 25 Ohm) and connect these wires to a 5V usb adapter and let it charge for approx 30 minutes.