Touch screen problem

Hello,

For Ubook 4100 Q256GH62061707

After a try to install HiPen H6 driver on my new Ubook (Serial number Q256GH62061707) which failed, the touchscreen didn’t work (x and y axis movements inverted, orientation not recognized, 90° turned with only part of screen accessible according to orientation) (same problem ….
So I try to get back to factory’s installation using Windows 10 internal restoration utility (OK … without reading all advertisements in forum’s many thread !).
After restoration, the touchscreen works but :

  • there is a cross on the screen which is not accessible with the cursor (a strip, about 200 px width, from middle-top to middle-bottom and another strip -same width- from middle-left to middle-right side of the screen). Cursor switch from one side to other when crosses strips and a touch on these strips results in a double-touch on both sides … (similar to)
  • some “auto-touch” occurs, sometimes several times per second, at the middle-right, top-right or middle-bottom areas of the screen, rendering the touchscreen unusable (need to disable the device in device manager to use a mouse …) ([similar to]
  • Touch with HiPen are shifted by several tens of pixels, even after calibration with device manager utility …

I installed official Ubook’s Windows 10 (from My Files) which should come with factory’s settings …
After installation :

  • according to device manager, all drivers in HID are “HID-compliant” Microsoft 21/06/2006 - v 10.0.18362.1 or .175 (no GoodixTouchScreen driver)
  • touchscreen has same problems (dead cross on the screen, auto-touch, cursor’s offset)
    I tried installation with different BIOS parameter (especially with “chipset > South cluster config > Miscellaneous config > Touch panel device” where default setting is “GT738X Touch DeciCe”… although there is a “Goodix touch device” setting avalaible ???), with/without Windows update after intallation, with user/administrator account, … Same problems each time !

I also tried to manually install official drivers (from http://www.mediafire.com/file/wudqu0od8bqbttu/UBOOK_drivers.rar/file) with different process and parameters (testsigning on/off, …) although I can’t find any information about “what driver for what device” … It failed too (drivers can’t start - code 10 -, touchscreen inactive or with same dysfunctions, …)

What can I still do to have an available touchscreen ???

4 Likes

I also have the same problem for my Chuwi 4100 and still got my screen error

Have you resolve this?

To fix it, need a correct cfg file.

Have you already fix this problem, cause maybe you can help me solve mine, also installed from forum the hi6 driver :frowning: ? Thanks you

I now have same problem is there a good bios flash available as no driver works. Also tried Kali Linux that worked before no longer works???

Same problem here. Issue occurs while in Windows, so decided to do a fresh install, had the same issue during the Windows set up, tried Linux, same issue. I would suggest a hardware failure or an issue in the BIOS. I have reported it to Chuwi via the website, but not yet had a response, as it was a Saturday, I am going to give them until late Tuesday before I chase through Amazon.

Ok. Where can I get this cfg file?

Try this one, I backed up it for my own. UBook 11.6 Windows 10 Driver

Hello. How to instal this? Where to extract? Should I manually update my drivers with it?

I need it too, mine is Ubook n4120 hipen h6 from home display driver gt738X comes up in bios.

Yo lo necesito también, la mía es Ubook n4120 hipen h6 de casa controlador de pantalla gt738X me sale en bios.

Did you fix it? I think I only need the cfg file :sob: