Ubook Pro Problems with the Pen

Hello there,

Ive finally bought a Chuwi Ubook Pro with the HiPen H6,

I use the Tablet for work and i have a problem with the Pen. The problem occurs in every program i tried: Microsoft Onenote, Microsoft Whiteboard and so on.

Often the Display is reacting wrong on my Input, for example my hand is on the Screen and i write something with the Pen, the Rubber option activates automatically, or a line comes up across the display to my hand.

I dont know how i can explain it more understandable.

In conclusion the Tablet reacts wrong on my inputs with the Pen when my hand is on the screen to write with the Pen. It sucks extremely when i try to calculate something or something like that and all the time the drawing programs do something different as i want.

Is there any opportunity to fix this problem?

Sorry for the bad english its not my main speech.

I hope someone can Help me, thank you!

Make sure you don’t press any button on the stylus by mistake as you type.

The stylus has palm rejection, so you will not write anything as a result of putting your hand on the screen, so that palm rejection is activated you must first bring the stylus tip close to the screen, without touching it, and then put your hand up

Hello,

Sorry for the late answer, i totally forgot to answer last time after i tested your tips.
Unfortunately your tips did not help me:(
Ive watched the problem now for a long time and i have noticed that the problem only occurs while the device is charging. Because of Corona i am in Home Office and i need the tablet very often, so i have to charge it very often while i work. Because of that i noticed lately that the problem occurs just when the tablet is charging.
When the charger is plugged off, then the pen works fine like it should!

But one more Problem i have noticed. The tablet is just 2 months old and it is a little bit bent?!

Dont understand me wrong, the tablet never dropped down or something like that, i treat it well and it still looks like new, so i cant explain me that except it has arrived so. I noticed this problem just a few days ago because its not extremely bent, just a little bit! I notice it a little bit when its on a flat table.

Maybe thats the reason why i have this issue. I try to take a picture of it.

Anyway maybe a reinstallation of the system would help? Because i am not happy with the pre-installed system. Its extremely laggy for a new tablet! It doesnt make fun to work with it. It just does not work smoothly! I tried different things like the virtual space, triver updates and so on.

My last try with this tablet would be a complete new installation of windows. And i dont wanna have the pre installed “chuwi version”. I wanna install a clean version of windows 10 pro, but i have read that there are problems with the drivers? Can anyone educate me about this?

Again sorry for the bad english, and thank you for the answers!

Have you tried to update Windows 10 to the latest 2004 version? The latest version works quite well with the UBook Pro. I would recommend trying that first before a complete reinstall to see if that helps with the performance issues.

Yes ive already upgraded the newest Windows 10 Version, but it did not help.
I looked again and i havent installed the 2004 Version, but there is no opportunity to upgrade?! Windows cant find new versions.

Well in that case you haven’t upgraded to the latest version yet, have you? :slight_smile:

The 2004-update is still rolling out gradually and should reach almost everybody by the middle of July. I’m also happy to say that it fixed the general laggy-ness of the Ubook Pro for me (I had the same experience as you), and it seems to do this for most people that have the N4100-version. So hopefully you won’t have to wait too long before you get it offered! :wink:

As for the bent-problem: Can’t really say mine has this problem, but maybe yours had this from the very beginning?

The pen and palm rejection can be finicky (as in unreliable), but it works great like 80-90% of the time for me since the 2004-update. Before the update, writing was too laggy and unresponsive to be usable. Again: I hope you don’t have to wait long to get the update offer.

Okay thank you for the answer, in that case i will wait until i can install an test the 2004 update before i do a clean install.

And yes i think the bent problem is from the very beginning because i cant explain to myself why how this could happen…