UBook Pro Touchpad Issues

Anyone having an issue where the touchpad shows up as a mouse and not a touchpad in the settings? I need to configure the touchpad because it has gestures when you swipe from the edge. So half the time I move the pointer down, it minimizes the window I’m on. It also launches the Notification Center when I move the pointer from right to left.

I found out a fix for touchpad, you have to disable left windows key to save the touchpad, you can mod the right alt key to right windows key also :wink:
https://tall-paul.co.uk/2017/03/07/chuwi-hi10-pro-keyboard-trackpad-fix/

1 Like

That behavior that indicates corresponds to the activation by you of the Windows gestures that you can know on the official Microsoft page looking for "Windows 10 gestures. It is true that they need learning and some, among which I include myself, I have not arrived to use correctly, but it is not a problem of the UBook or any device. If you do not get used to them in the end you can deactivate them as indicated above or simply, use a mouse, which is what I normally do.

Thanks for the reply. The only reason why I didn’t go with your approach is that I didn’t want to disable the windows key entirely. However, I wouldn’t be able to figure out my solution without your help. I realized that somewhere in the keyboard firmware it’s translating gestures into literal keyboard commands. Meaning that swiping from the right to open the action center is not a gesture but rather a literal “Win + A” being passed. Therefore, disabling those specific shortcuts globally solved the problem, as long as you’re comfortable with not needing to use that shortcut intentionally. I’ll post a reply to my original post with the specific things I did to solve my issue.

Unfortunately, the problem is that gesture input is not actually enabled. Because of the driver, the touchpad is only recognized as a mouse; therefore, gesture input is automatically disabled because the computer doesn’t recognize that there’s a touchpad connected to read gestures from.

Instead, what’s happening is that the firmware of the keyboard and touchpad is translating your gesture into keypresses and commands. So when you swipe from the right to open the Action Center, what’s being passed to windows is a “Win + A” command from the keyboard. Similarly, when you swipe down from the top to minimize the current window, you’re not using a gesture but rather “Win + Down Arrow” is being passed.

Therefore, gesture control from the Windows side will have no effect. I’m assuming that this was done intentionally to avoid the intricacies of creating a proper touchpad driver since this was a crowdsourced item. Instead translating at a hardware level might have been seen as an easier alternative. I appreciate you writing a response though. Maybe the solution I came up with can help you on your computer?

I found 2 solutions to my issue, pretty much, and would love the opportunity to explain it to you.

The Issue:

The touchpad on the UBook Pro is a little undersized. Therefore, during the course of normal use, I was accidentally activating the gestures for Action Center (swipe left from the right edge) and Minimize Current Window (swipe down from the top edge). You can imagine how frustrating that would be to have your windows continually minimize on you. When opening the Settings App, no Touchpad options are available. Similarly, any option referring to gestures is concerned solely with the Pen and not a Touchpad interface.

As @ryukenshin pointed out, a quick fix would be to disable the left Windows Key on the keyboard. But why, if Windows sees the keyboard and touchpad combo as a separate Keyboard and separate Mouse, would changing something on the keyboard side affect a response from the mouse side if Windows sees them as independent devices? Furthermore, why would disabling the Windows Key, of all things, have this effect?

On a hunch, I downloaded a keylogger program and recorded the swipe gestures and found that the swipe gestures on the Touchpad were actually passing shortcuts back to Windows to perform a specific task. That’s when the pieces came together for me. Disabling the Windows Key is a quick fix because the Touchpad itself is translating a gesture into a literal keypress that is being passed to Windows. So when swiping from the top edge, no gesture information is sent to Windows, instead a literal “Win + Down Arrow” is being sent. Disabling the Windows Key would naturally make the shortcut fail. However, I still wanted to be able to use the Windows Key on the keyboard instead of remapping it somewhere else.

I came across one solution on the Internet, and combined several different articles and stuff I already knew to create the second solution. Solution 1 is quick and easy and involves changing the registry to disable “Win + [Insert Letter Here]” shortcuts. However, since my biggest problem was the Minimize Current Window shortcut which utilizes the Down Arrow, that wasn’t very helpful. Solution 2 uses a combination of AutoHotKey and Task Scheduler to disable the “Win + Down Arrow” shortcut on each log on.

Solution 1: Disable Windows HotKeys in the Registry

First please read the instructions found here: https://www.top-password.com/blog/disable-specific-windows-key-shortcut/

Essentially, you can just create a DisabledHotkeys string value and store within it the [Inset Letter Here] for any “Win + [Insert Letter Here]” shortcut in order to disable the shortcut. Moreover, you can insert multiple letters one after the other wihtout separation of any kind to disable multiple shortcuts.

The registry key where the string must be created is here: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

I used this to neutralize the “Win + A” shortcut for the Action Center; however, this did not solve my Down Arrow issue for Minimizing the Current Window, so I had to move on to another solution.

Solution 2: AutoHotKey and Tash Scheduler Combination

I started wondering if there were a way to control in a script of some kind which keyboard shortcuts could be enabled/disabled. However, since these are Windows Key shortcuts, a lot of that is reserved at the system level. That’s when I stumbled upon this article (scroll to the response wiht AutoHotKey): https://superuser.com/questions/254603/is-there-a-way-to-disable-the-windowsarrow-key-shortcut

Since the instructions are not super clear on what to do, I’m going to write out some steps below:

Step 1: Download AutoHotKey

AutoHotKey is a free program that allows you, amongst many other things, to write short scripts to change the Hotkeys (keybaord shortcuts) that are currently enabled. Also, you can disable scripts at the drop of a hat in the System Tray. The program can be downloaded from the website. I can only post 2 links in my response, but the website can be found in the post I linked above and also in a quick google search or just add a dot com to the program name.

Step 2: Write Your Script

In the article where I discovered AutoHotKey (linked above) they were focused on the Right Arrow and Left Arrow hotkeys, but the premise is basically the same. Please note, something about having a literal “+” key there might make the script bomb, but since those are just comments for your benefit, removing everyting after and including the “;” on each line should be fine.

Anyway, you’ll want to create a new text document. I made mine in a AutoHotKeys Scripts folder I made in My Documents since I don’t like desktop clutter, but you’re free to keep your file wherever. I do recommend that you put the file in its final, stable location, as we’ll have to point to this location later with Task Scheduler. You can name the file whatever you want. Open the file and paste the text from below in, if you want to get rid of the “Win + Down Arrow” shortcut:

#down::return

Similarly, you can remap this hotkey and any additional hotkeys to whatever you’d prefer. The return simply indicates a “do nothing” sort of response. Save the file and then change the extension on the file from “.txt” to “.ahk”. If you can’t see the file extension, run a quick search on Google on how to reveal file extensions. Then you should be able to edit it by hitting Rename on the file and editing it there. Windows will give you a popup asking if you’re sure, so please hit yes to finalize the change.

And that’s it! The first time you try to open the file, you might want to hit Open With and point to AutoHotKey so that next time you can double click, but when it runs successfully there’s no popup box or anything. To know that it’s running, you should see an AutoHotKey icon in the System Tray, which you can Right Click to get more options, including disabling the script. From the moment you run the script, the remapped hotkeys should be effective.

Step 3: [Optional] Use Task Scheduler to Run Your AutoHotKey Script at Log On Automatically

So technically you have a working solution already. The problem is, every time you boot the computer, you have to manually rerun the script to get it going. While it should be as simple as a Double Click, it can be a pain to do manually. Therefore, I recommend using Task Scheduler. The app comes with Windows and can be opened by typing “Task Scheduler” into the Windows Search in the Taskbar.

When you open it, on the right you’ll see an Actions bar. You’ll need to start by hitting Create Task, NOT Create Basic Task. Below are instrucitons on what to fill in tab by tab in the popup.

General Tab:

  • Make the name and description whatever you want
  • “Run with highest privileges” -> Make sure this is checked
  • “Configure for:” -> “Windows 10”

Triggers Tab:

  • Create a New Trigger (tells Windows when the task should be executed)
  1. Hit “New…”
  2. “Begin the task” -> “At log on”
  3. Hit “OK”

Actions Tab:

  • Create a New Action (Tells Windows the task to be done. Here is where we will launch AutoHotKey and point it at our script.)
  1. Hit “New…”
  2. “Action:” -> “Start a program”
  3. “Program/script:” -> [Path to AutoHotKeys.exe] (Note that this path is in quotes. It’s best to hit the Browse button and navigate to the Program Files folder and click on the AutoHotKeys.exe file in the installation directory to avoid mistakes.)
  4. “Add arguments (optional):” -> [Path to script] (Note that this path is also in quotes and is the abolute path. Best way to get it is to go to the script file, hit Properties, go to Security Tab, and copy and paste the Object Name. Make sure to add quotes to the front and back of the path!)
  5. Hit “OK”

Conditions Tab:

  • “Stop if the computer switches to battery power” -> Make sure this is unchecked
  • “Start the task only if the computer is on AC power” -> Make sure this is unchecked (Since this is written for a mobile device, odds are you’ll be on battery a lot when first starting up the computer. Remember this is only for initial log on and not unlocking the device.)

Settings Tab:

  • “Allow task to be run on demand” -> Make sure this is checked.

And that should be it! Once your task is created, be sure to go to the Task Scheduler Library on the left. You should be able to see your task there with the name that you gave it. You can check if it works by first disabling the script from the System Tray if it is already running, highlighting the task in the Task Scheduler, and hitting run on the right. You should see the script start to run as indicated in the System Tray. Finally, upon restarting your computer and logging in, you should see the script running automatically.

And that’s it! Hopefully you find this helpful or can use it as the building blocks to solving your own issues. This solved the swipe from top edge and swipe from right edge gestures that were making the trackpad unusable. I hope that they update the driver so that Windows can actually see it as a Touchpad to avoid this mess. Let me know if you have any questions!

4 Likes

Thank you very much, great job. It is very nice to receive contributions from members of the published forum about their experiences and solutions found. Thanks again.

1 Like

Thank you for brilliant solution! On the other hand, I hope that someone with skill could modify the windows surface type cover driver to recognize Chuwi type cover. :grinning:

1 Like

Thank you so much for sharing :heart: :heart: :heart: :heart: :heart:

1 Like

It would be nice if chuwi would fix this for non techie people. Anyone else besides me need help do this fix? Chuwi really let the supports down with the touch pad problem. It may be cheap tablet but it should at least work!

Dear “Management”, This convoluted work-a-round, is not a true fix. This temporary hack job should not be seen as a permanent solution to a touchpad design flaw. I would hope that the engineering team is working on providing a driver fix so the precision touchpad settings are available in Windows. That would be the appropriate fix.

2 Likes

Is this the official response to a problem? Should we take that as thanks no go away we have no fix.

Be calm, this is a forum, not an after-sales service,

Hi Everyone! I just got an email from the crowdfunding page that says a driver update has been released for the touchpad. It definitely addresses the backlight issue. I haven’t had a chance to try the install myself, but here is the link they provided:
http://www.mediafire.com/file/ata1sg9drcfv5me/UBook_Pro_Optimize_keyboard_power_consumption..rar/file%203?r=slt-eml-bck-a2e0&utm_source=sailthru&utm_medium=email&utm_campaign=bck-01092020update&utm_term=

Thanks for sharing. A thread has also been created in this forum with the information. I already tried it and everything works 100%

1 Like

You already have an official solution to the problem. How easy it is to throw the stone!

1 Like

Hello, I have a chuwi hi10 pro and I wanted to know if the solutions of this thread work with my tablet.

If you about Solution 1: Disable Windows HotKeys in the Registry, yes, it works for all devices with windows system.

Solution 1 should work. If the trackpad setups are similar then even solution 2 should work, but I don’t own that device so I couldn’t say for certain. This post was ultimately resolved by a driver update that simultaneously took out the drag from edge shortcuts and making the touchpad appear in the settings app, making this solution essentially useless now. However, if you’re unable to get a similar driver update from the Chuwi engineering team (you’ll have to request it of the after-sales service) this will have to be your solution.

Also, I believe @ryukenshin has that tablet and pasted a response early in this thread talking about remapping the left windows key on the keyboard. All 3 methods attack the problem of not being able to control the keyboard shortcuts the touchpad generates and sends to Windows based on interpreting your finger input. If that’s not the underlying issue, then none of the solutions will help.

If you’d like, please try out Solution 1 and Solution 2 and let me know how it goes. Feel free to message me directly. I can’t promise to fix the issues, but I’d be happy to help as best I can!

If you want to disable Windows gestures, there is a script to disable them on your tablet: https://1drv.ms/u/s!AqpKvT8-VB_8gZI1Pura0Bz9tNrJNQ