What SSD disk type?

Is this disk is correct? The hardware socket, pins look different.

Is it safe to put and use this disk?
This disk is m.2 type.
I know only mSATA different in this size, but mSATA does not match the screw on the other hand. mSata use 2 screws. But Minibook has only one screw for SDD.

I am confused.

I imagine that your MiniBook is the version with Core M3 8100Y processor
This model supports M2 SATA SSD with MVNe format that has two groups of pins.
The SSD that you put in the photo is M2 SATA with NGFF format that has three groups of pins and is slower than the MVNe.
I don’t know if the shocket supports that type of SSD, I think not, but anyway, it is better to insert an MVNe.

I am not sure that you have right. Because I see MVNe SSD 2242 versions with 3 groups of pins. I suppose they use B+M mode pins which looks identically like NGFF, or almost identically. I do not know.

So I agree that my SSD is SATA NGFF and it is not working with M3 8100 device.
I have to use MVNe SDD absolutely, but its pins look similary.

I have a nvme drive with 3 sets of pins working fine on my m3 8100

What exactly vendor and model do you use?

I tried this one today, it is NVMe, and it is not visible by Windows.

image

I considered that one too but went with the Toshiba RC100

https://ssd.toshiba-memory.com/en-amer/ssd/rc100

Are you sure you have the M1 8100 processor? Maybe a driver issue?

M.2 port of the m3-8100y mini book is compatible with NVme and Sata My minibook m3-8100y currently works with a M.2 Sata Transcend without any worries

1 Like

Thanks for reply. Should I do something on BIOS or WIN after put SSD to make it visible?

Because, the second SSD I tried it is still not visible both in BIOS and WIN Disks Manager.

There is nothing to do in the bios for ssd to be detected
Just activate it under Windows disk manager and create the partition

OK. Thanks all for comments.
There was a BIOS settings in the booting menu. After changed, my SSD is visible under WIN now. No more problems.

See my message, there was BIOS settings. I have bought device without SDD card by default, maybe for this reason it came with such settings disabled. Curious, the settings is in the menu of booting :slight_smile:

I did not need to modify anything in the bios for my MiniBook to accept the SSD under Windows.
My MiniBook also was not delivered with an SSD has its out of the box

I Tried this one, but the socket doesn’t fit. I would like to have 1 TB NVMe SSD… Any ideas?

Sabrent Rocket NVMe M.2 2242 SSD

@JGJG did you manage to make your Kingspec SSD work on Minibook? Or you are using another one?
I’ve planned do buy one.

Situation requires clarification.
Connector on Chuwi is B type, that is typical for SATA M.2 SSDs. Despite this m3-8100Y minibooks support m.2 NVMe SSDs, but with this type of connector, that are quite difficult to find. I found KingSpec and another brand i don’t remember. So… The situation is this one:
-Celeron minibooks support only 2242 SATA SSDs (like Transcend) 550Mb/s B+M keys
-m3-8100Y minibooks support 2242 NVMe SSDs pci2x (like KingSpec) 2000Mb/s B+M and also 2242 SATA SSDs (like Transcend) 550Mb/s B+M

Usual NVMe SSDs with M key (like Sabrent) are not supported.

I plan to try a homemade adapter for the latter category, on the paper is possible, we will see…

PCIe Gen3*2 NVMe SSDs for Minibook m3-8100Y, 2242 size

Netac N930ES
KingSpec NVMe version
Western Digital PC SN520

Pay attention that first two brand make a SATA version too. The second one has no model number for NVMe version, so pay attention twice.

Of course i didn’t try them, but about the second i am sure (i read some posts about it), the other two on paper…