WIFI network card disappeared

Did it happen from the beginning or when it was received did it work correctly?
How long have you had the problem? Has it been after a Windows update?
If it worked before, you must reinstall the drivers verifying that they are actually installed and you do not receive a Windows message saying that they could not be reinstalled.
If you can’t see the device, first remove it from the device manager and then go to the menu, look for hardware changes

I use the PC for last 3 month was ok, it happen yesterday, no update in progress.
Already did all, reinstall drivers, I remove from device manager and reinstall it, still no coming out as network card, and at the end, I re install Win10 and did PC clean set up.
Can be a hardware problem ? Do you have any tool to throuble shut ?
Can I send print screen to your email ?

Do a Windows restore from the configuration menu, update and security, recovery, reset this PC. It is a long process and will take hours; put the charger and let it finish even if it seems to be stopped.

It does not seem like a hardware problem since Bluetoot is recognized and it is the same card that shares Wi-Fi and Bluetooth services.
Maybe you should also remove the Bluetooth driver to install it all at once.

I did already the recovery process, I let it work overnight.
Bluetooth remove already all at once and re install all at once.

Please see my screenshot


Alberto Bassi

I did already the recovery process, I let it work overnight.
Bluetooth remove already all at once and re install all at once.

Please see my screenshot


Alberto Bassi

can you see if the line “device unknown” appears in the device tree?

No devices unknow in devices tree.

It look like is a hardware problem !
The interface chip may works, but the modem side may be not.

I remove all my files, I did a factory reset and … still the same; no wifi card in the connections.

Il wifi dovrebbe essere tra i device nascosti. Il problema sembra del bios che per qualche motivo viene disattivo. Anche a con lapbook se… Iniziato con aggiornamenti w10 1903… Sembra risolto smanettando nelle opzioni network e antenne Wifi… Prova

controlla il bio … la scehda di rete è installata ma non visibile ( attiva visualizzazione opzione “dispositivi nascosti”)

Hi, I’m Atti from Hungarian Chuwi workshop center.
Her is a driver packChuwi Lapbook Pro Driver Download:
First, use the Intel driver support assistant to locate and install the Wifi adapter driver.

The wifi device was in hidden device… In my lapbook se for solve this I was entered in bios disable and enable network option. Save and exit and after reboot the wifi device was enable and full active.

1 Like

I have exactely the same issue. WiFi works fine for 2 months than after windows went on sleep and resume no more device. I tryed to install all drivers, reboot many times, nothing. I factory reset and fresh installed Windows. Definetly a bounce of time waste. It’s like laptop have no wifi adapter anymore. Following a workaround read in another forum, checked on terminal Netsh WLAN show interfaces give a completely blank answer. This is very strange as bluetooth works and the card is the same. If any further information need to find a solution let me know.

I am facing a similar issue. Instead of having problems with WiFi, my Bluetooth suddenly stopped working few days ago. An error getting device descriptor (code 43) is shown in Windows device manager.
I also tried to reinstall the drivers but it still is not recognised by the system. It does not seem a windows driver error since neither my Ubuntu does not recognised the Bluetooth device.
Moreover, an error is also issued in Ubuntu system log: BIOS contains WGDS but no WRDS. This error tipically refer to wifi errors. However, the WiFi is correctly working but the Blueetooth does not.
It seems to be a BIOS issue.
Anyone knows how to proceed?

Can somebody share a workaround to fix this seems to be a BIOS issue? Many here report this. Tryed to contact aftersale but get only bot reply from alisa …

I don’t that options in my BIOS. I only have these tabs: Main, Security, Boot and Save & exit.
How can I try to re-enable network option in BIOS?

sorry I cant help you :frowning: