Windows 10 Microsoft account logging in problem

As per title anyone has problem to set online microsoft account on windows 10. Mine is Chuwi Ubook X. It always mentioned of something went wrong, try again or tap cancel to set upn your device later.

1 Like

Are you trying to connect your account during the initial installation of Windows?
This is a well-known issue, turn off wi-fi and set up the system without network connection, after setting up the system it will be possible to connect the account.

same problem here with a gemibook. there was no internet connection during windows install and setup, it is impossible to login with microsoft account. Can you elaborate on the solution?

I asked Microsoft support and they said it has something to do with manufacturer’s certificates which need to be correctly implemented before connection to Microsoft server can be established. They asked me to contact manufacturer to resolve the problem. I already contacted Chuwi and they asked me to change to certain DNS server but it still doesnt allow me to connect to online microsoft account. One workaround is to connect using Edge server and subsequently Windows will ask you whether you want to use the account everywhere and I clicked yes. That then showed my online microsoft account on the login page.

I’m having the same issue with the Gemini Pro version they didn’t solve in its version updates…

Hi! I received my UBook X 12 today and I’m having the same issues! No way to login to microsoft account and change the Activation license of Windows 10… No one know how to fix? I’m trying to upgrade to Windows 10 20H2 but it’s working from this morning (and now are 18PM) and it has reached now the 97% of the update… Hope that it will update the system without giving errors… :slight_smile:
I was wondering about reinstall Windows from a Live USB pen but I’m afraid it will be difficult to find the right drivers…

Hi Andrea I hope it works and solve your problems, let us know if you succeed.

In my case, sadly I updated the system and performed clean W10 installation and none of this things worked.

Regarding your driver’s question, I haven’t got it but you can make a backup from the originals with pnputil in the cmd. With this command you will backup all the drivers
pnputil.exe /export-driver * C:“Name of the new folder you created to store them”

Here is the guide (in Spanish): ¡¡Hacer Backup de los drivers en Windows sin programas!! Administrando Drivers. - No Solo Hacking

I’ll let you know tomorrow, but if you say that I think it will not work…
I’ve wrote to assistance, we’ll see whats happens!
But honestly you told me a really INCREDIBLE TRICK! I didn’t know about that command! It’s a really gooooooooooood thing! Not only for that tablet but for everything! Thank you very much!

I was assisted by Microsoft team, we ended up with a fresh Windows 10 install from external drive, fully updated. Intel drivers have been updated too! Always the same problem, this can not be fixed. Microsoft ended up saying this can not be a software issue and it’s probably hardware related. At this point, it seems extended in the Chuwi line.

Only workaroud is the one suggested by mhawhazwan: using edge to extend microsoft account to windows. Sadly, this is an imperfect workaround since these won’t be properly synced.

You´re welcome Andrea!

I hope you can find the solution

Thank you!!

I’m gonna try now with a fresh Windows 10 install from Microsoft USB! Because the update ended with an error…:joy:
I’ve backed up all drivers and I’m doing now a RAW Copy of the internal disk to save the possibility to come back if something will go wrong with the hard level update! Thanks and I’ll update you!

Nothing to do, even with a fresh install of Windows 10 it still not available the Microsoft account… I think that is something in the hardware or in the Digital Licenze at this point that is not working properly, I’ll wait for Chuwi reply but I’m afraid that is not fixable…

Ahah it’s a disaster, after the update I reinstalled all the drivers but the touchscreen (I think it’s the touch because it doesn’t work and is the only one with a ! symbol) report an error failing to boot the device and when I try to update it by manually searching in the folder it report that the latest driver is installed yet… Trying to restore the old system Acronis freeze and won’t start with the restore!
I think that’s not a tablet but it’s a trap, definitely don’t worth 400€…
I’ll send it back and I’ll buy a Surface that will surely work! So sad about that because it’s well built and solid, but they made big mistakes with hardware and software components…

I’m sorry to hear that Andrea

I’m also thinking about returning my Gemibook Pro and get my money back because if it’s new and it has this problems which warranty do we have they won’t be worse in 6 months or a year…