A problem with the fans

Hello everybody,

I bought yesterday a herobox pro (8GB RAM + 256 SSD Version), everything works perfectly but unfortunately the fans are active all the time, is there any way to solve?
I also tried to change the settings from the bios but it does not work.
I also noticed from the task manager that the only movement of the mouse makes the cpu go from 4/5% to 40%, is it normal?

hi, i got the exact same problem like you. Running Linux, the CPU has an idle temperature of about 28°C and the fan is at max speed all the time. In the Bios you can set various things like “Active Trip Point Fan Speed” which should set different fan speeds for different temperatures, but the system is just ignoring them. Hopefully we get a bios update soon.

I really hope that, it’s quite annoying.

If I’m not mistaken the previous version of the HeroBox was completely fan-less, but had the problem of heating up quickly with possibly speed limits (the pc was automatic downclocked to lower the temperature).
This new version of the HeroBox has a fan, but it looks like it cannot be configured to lower it’s speed, the options are present in the BIOS but they simply would not work.
I hope the fan is connected on the motherboard (so that maybe one day a BIOS update could solve this problem) and not directly to the power supply (in this case it will run at max speed all the time with no chance of control).


I bought this miniPC on Amazon and there it was selling on the same page (for the same price) with the previous version (just a checkbox to choose between the two). So I thought this model is fanless which was very important to me as I’m using it as a HTPC (Home Theater PC). Imagine my surprise when I turned it on and heard how loud it is!!! It’s a mini PC and it runs at 38 C, why such a loud and noisy fan? This is a game breaker for me. Can this be solved somehow? Otherwise I’m returning it, it is just too loud for use as a HTPC and file server.

I have contacted the support, I will let you know as soon as they answer me.

1 Like

Good morning, I have the same problem, running Linux (Ubuntu 20.04.3 LTS) the temperature is low (about 28°C) but the fan is at maximum speed creating a very annoying noise :pensive:

They replied to me yesterday telling me that the fans will always remain active when turned on because it is not a smart fan pc

not a smart fan but connected with a 4-pin pwm cable on the mainboard xD

@Sierug thank you for the information.

Did they say they are supposed to run at 100% all the time? What are the Active Trip Points in Bios? Do they work? Can you share the support e-mail. Thanks.

What about swapping the fan for a different one? And also what about converting it into fanless?

“Hello HeroBox Pro is not a smart fan. The fan will run when it is turned on. This is normal.”

This is the complete answer that they gave me.

You can try, but i think you’ll lose the guarantee.

For just changing the fan? I doubt it.
By the way are there any schematics to see if the fan is somehow from a standardized size and easy to replace?

@gfawkest you can have a look on the amazon com site. There is a review of the product which contains a picture of the mainboard and the fan

what about disconnect the fan ? it will become to hot ?

I got the same problem


I’m having the same issue as you. The CPU idles at around 28°C while running Linux, and the fan is always at maximum speed. You can change items in the BIOS, such as “Active Trip Point Fan Speed,” which should set different fan speeds at different temperatures, but the system ignores them. We’re hoping for a bios update shortly.


The problem with the CPU fan always on is really annoying. It is really loud and I cannot leave it on unless I am listening to music. I have been trying to talk to the support but they always give the same answer (I am not sure whether they really read the questions): it cannot be changed. Therefore, I wanted to ask:

  • Did you try to change the fan with another 4 wire cpu fan? Would it work? Do you have any suggestion of model?

Since I saw the option in the BIOS, I was wondering if I could change it.

Thank you