CHUWI GemiBook screen flickering

Hi, I have just bought a CHUWI GemiBook 13". I installed Manjaro on it but I think this relates to any Linux distro.

The screen kept shaking and flickering with various glitches, until I came up with this solution by browsing various stuff online.

Create a file named “/etc/modprobe.d/i915.conf”

Write the following inside:

options i915 max_cstate=2

reboot

Hope this helps someone

never mind, the problem persists after a few reboot. Very strange.

Update: I’ve modified the line into

options i915 intel_idle.max_cstate=2

and the problem persists. Last time I booted and the problem was there, suspended and came back from suspension and it was gone. Firther investigation is needed.

Update 2: Now my /etc/modprobe.d/i915.conf file looks like this:

options i915 modeset=1
options i915 enable_guc=2
options intel_idle max_cstate=2

and I installed the package linux-firmware. Don’t know if they are all needed together but I got a clean reboot this time. Will update if I encounter more problems or I can shrink the solution

Update 3: this time it seems I got a stable boot which doesn’t require suspending and then resuming from suspension. To the previous configuration in /etc/modprobe.d/i915 I have added:

  • after reading Kernel mode setting - ArchWiki I’ve added to /etc/mkinitcpio.conf MODULES=(i915) and regenerated initramfs
  • after reading my /var/log/Xorg.0.log file, I saw this lines

[ 14.809] (II) LoadModule: “vesa”
[ 14.810] (WW) Warning, couldn’t open module vesa
[ 14.810] (EE) Failed to load module “vesa” (module does not exist, 0)

so I thought I’d install the package xf86-video-vesa. After rebooting the error is still present, but the flickering is finally gone across reboots (for now)! So I proceeded undoing everything else, thinking the mkinitcpio.conf was the solution. It indeed was, so I only left the guc enabling inside /etc/modprobe.d/i915 because seems a feature that could make sense to have enabled.

I’ll post any updates if the problem comes again. Now off to the missing audio problem… (btw this errors aside, I really love the look and feel of my GemiBook!)

Update 4: I tried installing 5.17 kernel to make sound work, however this broke the screen again, even with the above solution. Reverting to 5.15 works again

Update 5: it’s been a few days, and compiling my own kernel at the latest version seemed to fix all screen issues