Chuwi Hi10 Fresh Reinstall

May be you have bad EMMC(internal hdd). It’s common problem. If you can’t format or clear EMMC you need to resolder new one.

I tried this Toturial for Reinstall. This only works with the oem Version from Chuwi. Can be found here

But i got an error that the scrip could not create “W:\recycler\scratch Folder”, so it went red and nothing happend. Got this Problem after an Build-Update on 8/22 for Windows 10 1903 (19H1).
If someone can Help me with this special Problem please do so …

So, i took a look in the cmd and found some mind blowing lines: from DiskPart:

DiskPart succeeded in cleaning Disk.

The disk you specified is not MBR formatted.
Please select an empty MBR disk to convert.

Looks like it’s not formatting the drive or assigning the drive letters…
Let’s give it a try on the 2nd device …

Thank you very much @Huans!

But where to find these OEM files? I only have Windows May 2019 Update files I found here Windows 10 May 2019 Update ISO File

Could you each explain your problem to be able to provide personalized and not general help in each case?
It is an easy process and will be resolved quickly

Here are the official Files from Chuwi: Hi 10 Air Installation files

Edit: Repacked the Original Files from this Forum and repacked them. Using other Hosters for a better availability: Share-Online, Uploaded via Share-Links
These Downloads are 200MB/Packet so you can also load it with slow bandwith and as free user.Password for share-Links Page will be Chuwi

My problem is that I cant reinstall Windows 10 by regular means.

So far Ive partitioned my USB drive to GPT and NTFS file type. I used Rufus to copy the original Windows 10 iso file on the USB.

I can boot the USB and go to setup. Once there, where you can choose to Format it gives me an Error. When I try to delete the partition it does nothing - the screen refreshes and thats it.

This is why I came to forum to look for help. I will try again with @Huans instructions and see how far I can get.

Also, I want to mention that it does not save any type of Windows configuration. It just reverts back to how it was. I am starting to think that it might be hardware issue but I am willing to try anything before having to send it overseas to claim warranty.


I have not used Rufus to install Windows since from the Microsoft website you can directly download Windows 10 home multilanguage with the media management tool in a flash drive.
Once you have it, start with the pendrive by pressing F7 intermittently until the boot selection menu comes out.
Choose the pendrive and in the menu, install Windows. On the screen where you are asked where you want to install Windows, you must remove all partitions, selecting one by one and clicking on the delete button.
Once deleted, a resulting unallocated space will remain. YOU DO NOT HAVE TO FORMAT, just select that unallocated space as the installation destination and press next.Windows installation will begin.
When you ask for a Windows password, click on the “I don’t have a password” button since Windows will be activated only when you connect to the Internet.

In my case that option didn’t work even with an insider or other Windows versions. I can not format the partitons or delete them. What i’ve read from @ArianSR he maybe have the same problem.
After rebooting Windows I’m always on the same state like before.
No files are erased or fresh files added aren’t present at reboot.
So it is not possible to look for an error-message cause it’s not written to the eMMC.
Is there a way to check the eMMC for corrupted sections that may cause that problem?


Try this, logically only with the Windows partition

I’ve already tried this, also set the partition type to MBR bevor using starnet.cmd. Didn’t work in my case. I can see the print out that It’s using the pre-Installtion commands for SingleOS.

And how about trying a clean installation of Windows. You will need a multilanguage windows 10 home pendrive with the media management tool and the forum drivers.It is not complicated and could guide you to remove Windows partitions during the installation process

Was the first i’ve tried but as you can think it’s not working. Windows is performing a reboot for this action. But on rebooting it starts normally as before without doing anything other. Also tried a Memtest from Windows but it’s not executed on reboot.
Reinstallation waas my last option bevor sending my tablet in for repair, i’ve tried all ways (that came up my mind) to solve the problem but no Solution till now.
Maybe I really have no other way then sending it to Repair. Could be an option even for Chuwi to get some Information how it comes to this kind of Error.
First i thought it is a Software problem but know i Think it depends on the Hardware.

1 Like

This is a 99% hardware problem. There are a lot of people with such a problem on the russian 4pda forum - after deleting files, they appear back after a reboot, formatting does not help, restoring windows too. If you upload some files to disk and reboot, they will disappear or will be corrupted. Only replacing emmc helps.
It’s called “read-only” emmc status.

1 Like

I just want to confirm that none of the steps above work. I think this is an eMMC problem.

@manonegra222 is there a PCI-E slot inside the Hi10 Air? Are the both eMMC and Wi-Fi adapter embedded or are they in a slot which make things replaceable?

Sending the tablet overseas and paying for return shipping is almost the same price as getting a new PCI-E MMC. So just looking at my options here.

I was watching a video of a similar model being disassembled and apparently it has two places for an PCI-E slots that can possibly be added.

However, in this model (Hi13) eMMC and WiFi are soldered to the board without possibility to just detach and replace them. But seems like extra RAM could be added in the future. :slight_smile:

Pci-e slot is not soldered and I do not think that it will work if soldered because some components are missing nearby.

1 Like

You can try “Windows to go” to boot from a regular flash drive.

All components are welded to the motherboard, which makes them irreplaceable for uninitiated people. You can check what would be the price of a new plate to replace it in your country.

1 Like

it’s possible. You can try