Hi10 Air Windows Reinstall - no image for this serial on forum

Hi there !

I have a CHUWI Hi10 Air CWI529 (Hi10 AirQ64G1911XXXX),
and I haven’t found any corresponding Windows images (files) on the forum.
I tried this one, and other ones too -> [Hi10 Air] [Official Version] Chuwi Hi10 Air Windows, driver, Bios download
RS4 and RS6 too, totally following everything that’s been said.

So far, I can F7 into the bootmenu, but when selecting the flashdrive (yes, named WINPE, NTFS, 4096 etc), only thing I see is a black screen. Thought it takes some time to load, but no.

Could someone (management maybe ?) please help, how I might be able to proceed installing Windows on it ?

Thanks !

1 Like

Use this tool to create usb drive. If you still see a black screen, write to service@chuwi.com .

Unfortunately it doesn’t work either, I’m still getting a blank black screen.
Also tried renaming from “ESD-USB” to “WINPE” just in case, aaaaand no.

I’m writing to the service, and posting this thread.

Thank you for your help !

If you are doing everything right and the installation of the system does not progress, you should try another pendrive, since some contain hidden directories that prevent the progress of the installation

Although I’ve read your recommendation earlier in other threads too, and understand why that could be an issue, I specifically chose a flashdrive when I bought it, to parry any issues like this.

For good luck, I will try the Media Creation Tool method once again with a different flashdrive in an hour, and share the results here afterwards.

You will need to install the drivers later in case you opt for clean installation with a Windows 10 flash drive with the media creation tool

In case, if you are looking to reinstall windows store then follow the steps given here to again.

No, I’m not trying to reinstall the “Windows Store”, and please don’t try to scam people with your malicios link. Reported to the staff.

Alright guys, nothing worked and service@chuwi.com didn’t get back to me.
Tried with Linux, FreeDOS, Hiren’s boot CD, etc…

Looks like whatever I’m trying to boot from, it’s kind of like in a bootloop, and doesnt want to do anything except showing me either only the logo, or a black screen.
Any other ideas ?

Are you using usb hub? Try another one. Also check in bios chipset->south bridge->lpss&scc configuration there must be EMMC name at the top. If it’s unknown you may have hardware problem.

In BIOS->Chipset->South Bridge->LPSS & SSC Config.:
“SCC Configuration - eMMC: Unknown SLD64G 130C0392 (57,6GB)”

Yes, tired with three different ones.

I’m pretty sure it is not a hardware problem, as the device is basically 3 weeks old (out of which it worked for the first two days), it worked fine before, until someone tried to fresh reinstall Windows on it. Of course formatted everything, hence nothing boots up, but that doesnt explain why the flashdrive, or external ssd, or anything is not being recognized as a bootdevice, and why it doesnt boot just hangs on the American Megatrends BIOS POST screen. It’s definitely not a hardware problem.

To some people in Russia the tablet came with an already faulty memory and it worked until the system was updated or reinstalled. They either had a logo or a blue screen of death. Also, some laptops hang on the logo with a faulty hard drive.

I’m in Hungary, so relatively close to Russia.
What is the solution in these scenarios ? aftersale@chuwi.com ?

Sideinfo : The BIOS randomly keeps freezing, and the boot order sometimes can’t be changed, as well as it doesnt do anything for the option of opening an EFI shell.

The solution is memory replacement.
But wait for service answer, probably they will offer some solution for you.

And probably if you disassembly the laptop you will find painted dot on memory, I’m not sure what does it mean but all tablets with “unknown” memory has it.

Oh well for warranty reasons I won’t open the tablet. But it’s a bit weird for me, because even if I just try to boot from a flash drive into a Live Linux distro, it doesn’t boot, and that has nothing to do with the eMMC on the motherboard. But quite interesting.

Compare bios settings just to be sure it’s correct.

Security -> Secure Boot menu
For me, it’s not SETUP but USER
And my Vendor keys are active.

Everything else is the same.

Okay guys finally I legit fixed it.
It was way easier than I thought.
No issues at all.
Picture as proof.


1 Like

What about this?
I don’t know where ticket goes, probably to aftersale@chuwi.com