Chuwi HiPad Pro hard reset doesn't work


Can’t make an hard reset on Chuwi HiPad Pro…
Power-Sound+ combination doesn’t work, power-sound- combination either.

Forgot the password and that’s why I would like to hard reset …

Any suggestions?

1 Like

Yeah, I recommend you to follow this video, It’s in spanish so if you need help to understand it feel free to contact me on discord!: @muacky

Hi thanks for the reply.
But first… This is the chuwi HiPad x not the chuwi HiPad Pro. The power button is on the left and smaller side of the tablet.

And of course I did the same thing … Pushing both buttons same time… But the boot menu never appears.

Hope for more help
Thanks a lot

I thought it might also work for you as it worked for me (I have a Hi10 Pro)

try holding the volume up or volume down button while you REBOOT the tablet

I have the same problem. Tried “all” videos, But nothing works… Holding power and volumen + or - did not work. I tried with usb cable… did not work…

Any New suggestions?

When the machine is on, press and hold the power button + volume up button. After the screen goes off, release the power button (without releasing the volume up button). When the small robot appears, release the volume up button. Press and hold the power button + volume up button.

This is what the tech guy told me. I do not have here a model to make a video because is old, but if you guys can try a make a video for future people reading this…
Let me know

@manonegra222 :slight_smile:
@Peal @Tom7

You should try, with the tablet turned off, press the power button and immediately the volume button - (leaving the button pressed) until the Android menu appears