Chuwi UBOOK touch screen stopped working

Hi,

the touch screen on my Chuwi UBOOK stopped working all of a sudden. I tried reinstalling the drivers with the ones you provided in another thread, but it still won’t work.

When I open the Device Manager, the problem seems to lie in the I2C HID Device, whose status is as follows:

This device cannot start. (Code 10)

A request for the HID descriptor failed.

Hope you will be able to help me. Thanks in advance!

Do you know if the drivers were installed or gave you a message that could not be installed or that the best driver was already installed?

Indeed, according to Windows the best drivers were already installed - I also tried to update the drivers in unsigned mode, but Windows still told me the best drivers were installed.

You are not doing it for the right place, you must use the option below “Search for driver software on your computer” on the first screen, on the second, the option below “search for a list of drivers on your computer”, and in the third screen “use disk”, selecting the disk folder in which you have unzipped the drivers and leaving the option “search in subfolders”
Follow these steps and you will get to install the driver

Yep, did that already. It still told me that the best drivers were already installed.

remove the drivers and do it again

Did that too, to no change.

Last step: Restore Windows
Start, configuration, update and security, recovery, restore this PC -when you ask, mark that you want to keep your files-, put the charger and let it finish, it will take hours and even if it seems that it is stopped, be patient and wait.

Just tried that. I2C HID device still giving the same error code 10…