Chuwi Ubook X Drivers

I did a full drivers backup for my Windows 10 Chuwi Ubook X 12". I’m sharing the link to it here as I’ve heard quite alot of members are having trouble looking for one. Hope it helps.

2 Likes

Thank you, I also have a lot of trouble in re-installing windows 10.

send your email. I’ll share the stock rom with drivers for the ubook x and instructions on how to install windows 10

1 Like

My email:
tangohd@gmail.com
Thanks

no prob. check your email. Windows 10 for the Ubook X is over 7GB so I’d suggest to dont sit and watch the download progress

Woud you mind to send me the stock Windows 10 rom too? My email is david.gabriel.31[at]gmail.com. Thanks in advance!

Thank you so much. Downloading now!

I tried and the installing of windows 10 was good.
1 driver missing but I found it on this forum.
Now I have the ghost touch problems :sob:
Sometime it the cursor moves like there is someone touching the screen.
Any ideas?

Update windows 10 until there are no more updates or install Windows 11

I moved to windows 11 but I had problem with h7 stylus pen and bluetooth ear phones.
So I decided to went back to 10. The ear phones now work and the h7 is still stopped.
This is the third time I format and re-install windows 10, the first two times with a microsoft
image, last time with the 7gb image I download from here.
Each time the same problem: there is a ghost that is touching my screen on right part of touchscreen every 10/15 seconds.
Before formatting Chuwi does not had this issue.

Now I tried to change Touch I2C driver with KMDF HID Minidriver for Touch I2C Device
The ghost touches are disappeared but the screen is not touch any more :frowning:

What kind of drivers have you got on your Chuwi Ubook X 64 for HID I2C?

That’s odd. Since I upgraded to Windows 11 I haven’t looked back. My H7 pen works well too…

Try the link I posted. That ROM is directly from CHUWI

I tried that ROM and ghost continue…

Have you installed all updates after installing?

U have to go here:

UBook X CW1535 Digitizer / HiPen H6 Firmware needed - Windows Tablets / Other Models - CHUWI | Official Forum

Really thx…giroscope now is working back!

This happens to me if I have it charging with ac adapter. It affects alot when im using the stylus. If its not charging, I don’t have problem.

Yes I did. At last I solved with Kinoko files.

(https://forum.chuwi.com/t/ubook-x-cw1535-digitizer-hipen-h6-firmware-needed/15646/2)

Hi guys, that driver package is great! Thank you very much.
Just 1 driver is missing in the archive, here it is:
Kionix CJ9-TJ9-TJ2 Windows Drivers 1.28.3.zip

If you want, I uploaded here even an updated version of the archive from @Faifaifai, including Kionix driver and Phoenix hid update:
Drivers_Chuwi Ubook X_v2.zip

1 Like