GemiBook Pro 14 - right mouse click on touchpad isn´t working and the fan is running on full speed

Dear Chuwi Fans,

my brand new GemiBook Pro 14 inch Intel GemiLake Quad core 16GB+512GB arrives me yesterday and the touchpad`s right mouse click was dead on arrival. No mechanical clicking occurs like the left one. The mechanical touchpad issue was reported to the aftersale@chuwi.com and I wait for a response. An other issue is the fan is running constantly in full speed and the ssd seems to be very slow in write speed. I did not messure the speed actually, but the first windows update takinging very long. I will observe it. My question here is, is this an known issue and how can I drill the fan speed?

Best reagrds from Germany
JuD.S

Hello,

I confirm the problem with the fan. It is impressive the speed it reaches even in idle mode, it causes a very uncomfortable noise. The CPU model does not justify this, there are laptops of other brands with identical CPU and they are fanless.
I do not understand how CHUWI allowed this model to go on sale with this problem, at this moment I am more than sorry to have purchased CHUWI.

I hope that the fan’s high speed problem will be solved with a firmware update, very soon.

Dear Overlord19,

could you show me your termal setting inside the BIOS under advanced? For my opinion all is disabled, may be this can be the root cause of the full spinnging fan.

JuD.S

I have default settings that come with laptop.

May be this will not be configured well in default.

JuD.S


These are my unedited bios settings. Fan is running permanent.
If someone has a working configuration i like to hear it.
If i find one, you are the first to know:-)

Exact the same setting here.

JuD.S

Exactly same issue here where the fan seems to be running all the time at constant speed, generating unnecessary noise. This seems to be an issue across all Gemibook Pro, I sure hope Chuwi would fix this urgently. Please update us soon.

Yes same settings here. CHUWI please fix this issue asap! Not acceptable.

1 Like

Dear Chuwi, the same for me.
I’ve received a brand new GemibookPro 16GB+512GB.
It works well but fan is running constantly, the BIOS settings are the default ones.
Any idea to solve the problem ?
Thanks

Dear Chuwi, same issue.
Waiting for your answer.
Thanks

Hey guys! Greetengs from mother Russia! I’ve solved this issue) Just open back plate and unplug the fan)) Then I start stress test AIDA64, 100% cpu, 100% gpu. Temperature quickly up from 44 to 65 and… That’s all) After one hour of working stress test with charging max temperature was 69. No throttling, no freezes, no overheating. Intel’s official site tells that’s max temperature of celeron j4125 = 105C.
Enjoy your absolutely silent laptop without throttling! Chuwi, thank you!

2 Likes

TRACKPAD PROBLEM WITH THE GEMIBOOK
Similar problem.

I have 3-4 months with the gemibook 12GB RAM, and in the same first week of arriving the trackpad just went dead. I tried to solved it by the usual steps. After 1 day or 2, It came back surpringly. Right now, 4 months after, the same happened, Im writing from my other pc cause the GEMI trackpad is dead AGAIN.

Thanks in advance for you feedback.
Really dissapointed of this pc.

Dear Ariel,

my trackpad issue is an mechanical issue - right click is not clicking. Your`s sounds differnet, but thank you for your message.

JuD.S

I have the same problem with the fan of the gemibook pro, this isn’t normal, how can I solve it?
Please someone can help me?
Thanks in advance.

I have the same problem with the fan speed. Please solve this issue!

i have GemiBook Pro 14"… the problem is the laptop is always automatically shutsdown randomly… is the any solution for this… is it the BIOS or hardware component itself…
any help is appreciated…

Thanks Maxo, I tried disconnecting fan and so far all seem OK, slightly warmer but nothing alarming. Beware that this is at your own risk, but if you wish to try, there are screws underneath two of the rubber feet and the fan connector is about 5mm with 4 different coloured cables leading to the fan. Good luck.

Same here, the fan sound is very annoying, full speed all the time, even without any processes going on…Has anyone found any solution for this (apart unpluging the fan manually)?

p.s. why there are no official answers from Chuwi? It seems that they doesnt care at all…

why there are no official answers from Chuwi? It seems that they doesnt care at all…

Here the answer for your question.

1 Like