HELP: Official Windows Update broke the Hi10X for everyone!

Dear Management,

a recent official Windows Update completely broke the CHUWI Hi10X (N4120 version),
there are several detailed posts about it in the Hi10X forum section
the update is called Firmware G8320
and it messed up with the BIOS, the consequences are:

  1. 3Go of RAM hard defined in BIOS instead of 6Go
  2. there is no sound hardware detected anymore
  3. there are some unknown devices in windows devices manager,
    and it’s impossible to reinstall them even with the good drivers

The solution answer from your support was to reinstall and reset everything to factory settings,
but it doesn’t work! The problems are still there.

Some people are asking for the official BIOS file and flashing tool to do it properly.

Can you please with your technical support:

  1. firstly aknowledge the problem? (to reassure people)
  2. tell us if you are searching for a solution? (for us to remain patient)
  3. provide us the BIOS file and flashing tool? (to see if it resolve the problem easily)

I’m really happy about your products so far, and have several Hi10X used professionally at work,
it’s very important for me to have a solution really soon or I will have to replace all the non working devices and it will be a giant let down.

Thank’s in advance for your help and support,
Best regards,



why on earth someone will update the bios?

The fact is that we didn’t update the BIOS by choice. We received a firmware update on Windows Update and installed it accordingly. I don’t know if this the real target of that firmware update was the BIOS but, as you can read from mine and other user accounts on the recent threads, we are now facing the aforemented issues with sound drivers and RAM listed as 3GB instead of 6GB.

I personally performed two clean installation of both Windows 10 and Windows 11 using the official MS media creation tool and then installed my personal drivers backup collected with DISM command when I first received the tablet. Everything was recognized and was working perfectly.

Then this update…a nightmare…

I had the same problems after the update. I deleted Windows and installed Fedora instead → RAM went back to 6GB.

I don’t know if the 6GB remain, when I install Windows again. I’ll stay on Fedora for a while.

1 Like

same problems, reinstall windows through sd and reset bios , it doesn’t work

Hi Ccchan,

thank you for you insight, of course I do never update BIOS for the pleasure of doing it,
in this case as said by AgentM it was not even specified as a “BIOS Update”, but only a “firmware update” and the update was not specified as “optional” in my system.

I have 12X Chuwi Hi10X with Win10 Pro used in my company,
and the updates are absolutely mandatory tu use them with our local network server, we don’t have the choice, we cannot refuse or block signed official update from Microsoft update.

What I’m worry about, is that Chuwi don’t say anything, and I fear it will stay like that forever… too bad for the poor people who have installed this cursed update.

And with 3Go of RAM left, the tablet barely run the OS and is so sluggish it’s impossible to work with it.

Thanks to your other post I’ve seen that I probably have an Everest Semi ES8336 sound chip, and was able to manually reinstall properly one of the two missing devices, I now have the ESauAudio Driver correctly installed and said to be working, but still no sound, and still the I2S Device not installed (I tried every Realtek, Intel High definition, Intel SST and Everest drivers I found, but no result)

I don’t know what else to do, and can’t install LINUX for my use…

So please CHUWI, Help us!

Thank’s in advance to anybody who can help.
Best regards

1 Like

Did you manage how to get sound working in Fedora?

Yea, with the tip mentioned in this issue:

And i had to switch Audio from headphone to speaker.

Exactly the same problem and attempted repairs on my H10X. Sent email to Chuwi sales and got reply to send problem to Chuwi service. Hope they provide a solution soon to missing drivers or bios fix.

Right now using bluetooth headsetfor sound as work around.

1 Like

then… howcome it is blamed to be bios problem? only affect windows but not linux?

Did you do anything special when you installed Fedora so the tablet could recognize the rest of the ram?

I thought it was just a driver issue at first, so I even went back to a Windows 10 image I did when ai first bought the device, but Bios only sees half of the ram.

Maybe if Fedora undoes the firmware update Windows will be able to see the rest of the ram?

Thanks dkdwong for the bluetooth audio solution advice, I was actually using an usb external soundcard and didn’t thought about the bluetooth solution, which is far more convenient until an official fix from Chuwi… :slightly_smiling_face:

I deleted all Windows partitions and let Fedora install itself on the whole hard disk. No dualboot.

Memory info


Hardware info

if linux CAN recognize the 6GB of ram,
i really doubt it is at the bios level.
i could not be sure, but i really doubt that.

i guess if you claim it’s the chuwi/update hurting your bios,
you are the one who should provide evidence to it,
NOT others to provide evidence that it is NOT.

Did you install one of the spins like KDE or XFCE, or Fedora Workstation? I installed workstation, but the ram issue didn’t change, and the system kinda goes unresponsive every 5 minutes.

I installed KDE Spin.


seems only for ess386 sound chip variants.

1 of my 2 intel variants survived the update.


same problem on my device.
So I installed SUSE tumbleweed. But only 3Gig available. Sound only works on my bluetooth earphones.

Hi everybody,

thanks to all for your support or for posting that you encounter the same issue (and keep this thread visible), I feel really sorry for you all in trouble, but honestly I don’t have hope anymore to have an official fix or help from Chuwi…

I’ve written them several direct messages (clear, factual, detailed, patient and polite) but have not received a single answer!!
they cleary don’t care about this issue (and their customers)!!

And from what I read everywhere for other products and their history, their support and aftersale service seems non existent…

After trying everything to recover the BIOS, re-installing fresh Windows image (official Chuwi package or Microsoft media creation tool), or manually messing with all the possible drivers, I just give up to find a solution,
without a proper patched new Firmware (or Linux) it seems impossible to troubleshoot it by ourselves…

So thanks to all,
Best regards

just 1 Q:

is your hi10x/r still in the 1yr warranty period?