CHUWI BIOS Firmware Hi10 X N4120

I performed a clean install of Windows 11 last week and installed all drivers backup I had collected from DISM command when I first received the drvice. All worked perfectly fine.

However, yesterday, Windows Update showed me an optional update of a firmware which I sadly performed. The update went smoothly but I noticed two things:

  1. at boot, just after Chuwi boot logo screen, it appears another screen with a message in chinese which I’m not able to decipher. It refers to some LAN info…

  2. sound drivers went missing and i was not able to install my backup as it showed me that they weren’t the right device drivers. After a lot of research I was able to install some intel smart sound technology drivers, but still audio is not working.

  3. in system info, the RAM now shows 3GB instead of 6GB!

I think this firmware update messed with the original chuwi bios firmware and the devices info such as the sound devices…i don’t know…

I would like to flash an old version of BIOS firmware. Can someone provides it?

I have this model:

Chuwi Hi10 X
Intel N4120 6GB RAM
Intel UHD Graphics 600
Model: Hi10XG128G210208985 CWI529

1 Like

Have the same problem with Hi10X but with Win10 optional update, shown as G8320 Firmware Update. Answer from Chuwi support was a reinstallation/resetting to factory state of Windows. But the Firmware was not effected from this. And now my system is “clean” without all my programs and data und the problem of no having audio and showing 3GB RAM instead of 6GB is still present.
I think we need at 1st the old firmware!!

Extactly the optional firmware update (G8320 Firmare Update) I received and that messed up with the device. I strongly suggest to avoid installing it until something is sorted out.

Hopefully Chuwi Support will deliver a BIOS firmware to restore it because a simple clean install doesn’t solve the issue.

Hey! Found Solution for issues with Hi10X
There is a link to a Firmware ( Bios.rar). Dont know if it will work. I just cannot test it because I’m on a journey next 2 weeks. But this is definitely not the Windows recovery I got from Chuwi service. After reflashing I think it*s a good idea to check all settings in BIOS (don’t know if all will be kept). Good luck for anybody who will try it.

To be honest I would prefer to flash a file sent directly from CHUWI service. We don’t know if the one published on that topic will be useful…

I hope CHUWI Support will answer back to my email.

I have the same problem.
We are waiting for link to BIOS/flash-utility from the official Chuwi support!

My problem is the same: no sound, I 'm also waiting the solution from official chuwi or anyone. My chuwi type : CWI529, serial: Hi10 XG128G210207304

Hi everybody,

I just got the Firmware G8320 install from Windows Update and like you 3Go RAM now and no sound anymore…

I tried to look at the BIOS but no way to restore anything to a working state.

Could we at least have an official answer from CHUWI please to know if anything will be done to save our tablet or if they absolutely don’t care about the problem?
I have no problem to be patient if a solution will be provided
but waiting for nothing is irritating.

it seems that some people have this problem for more than 8 days !!!
the only official answer seems to be to reset to factory install,
but it doesn’t solve the problem!

Should we just throw the tablet and never look at Chuwi again?
I’m really disappointed because I was really happy with it until now,
and I don’t understand why the support can’t give us a proper BIOS and flashing tool like any other manufacturer would have already done…

Thank’s to anybody if a solution will be found.

it’s interesting that searching about the new chinese splash panel (214-230049) with logo it is pointing to a radio certification from Chuwi itself:

so it was probably an intended firmware update, but there was something wrong with it, or it was supposed to be for another product…

in my device manager I have now two devices without drivers:

  1. an I2S device (which is probably related to the lack of sound according to the fact I2S seems to be a protocol for Realtek products)
  2. unknow device (on Intel(R) Serial IO I2C Host Controller - 31B2)

I tried manual installations with drivers I found online to restore them, but without succes.

I hope we will get an official fix really soon from CHUWI, this is not acceptable for a consumer product.

Yes, that splash screen with 214-230049 seems to relate to some conformity certification for LAN.

The missing I2S device and Unknown device IO I2C Controller 31B2 are the sound system device. After the firmware update their drivers went missing. I tried my backup (collected from DISM command) to no avail. I was able to install a backup called “” provided by a user in one of the many threads on this forum (I don’t remember the exact location). They were now recognized as “Intel Smart Sound Technology” which was not the original label (if I am correct the original label was Intel ® High Definition Audio or something similar). Anyway, there was no sound even with these smart sound drivers.

Chuwi please help us!

1 Like

there are 3 variants of hi10x/r as in my old post.

better sort that out.

Hi all! I was surprised, too, by the firmware upgrade and the splash screen with Chinese text. But, besides the (very) ugly boot screen, my Hi10X has no problems with sound or memory size.

My stylus isn’t working, but it didn’t work before the firmware upgrade.

Hi harlleysathler,

thank you for your insight, it’s very reassuring, could you please tell us which serial do you have?
(so it seems that not all Hi10X variant are affected by the bug!!)

Would it be possible to share a screenshot of your audio/video/game controller tab of your windows device manager? (to see what should be there)

And if I may, would it be possible to share some screenshot of your bios (version)
and maybe some of the main tabs configuration (north bridge / south bridge) and maybe the HD audio panel of the BIOS?

It would be so much appreciated, Thank’s in advance!

Very strange! As Pirahna-A asked, can you plesse share some info abour serial Number, model, BIOS version and settings?
This Hi10x Is so strange…so many variants!

Hi! Sorry for the long delay. My serial number is XG128G210411616.

This is how my device manager looks:

And the BIOS screen shots:

1 Like


others say it is compulsory.

who is lieing?

tell you guys,

usa keep on pressing china.

we just no longer have affordable chinese products.

i dont think there are rich or powerful people among us… so… that s it

I have a hi-10-x n4120 and have EXACTLY the same problem after a Windows update.
1.) new message appears in Chinese on booting
2.) audio not working, reported as “audio device not installed”
3.) RAM showing as 3GB instead of 6GB in sysinfo and bios

Hope there is a solution as Windows 11 has become really sluggish, presumably because it is trying to run on 3Gb

Thank you very much harlleysathler for all the screenshots and the time you spent, you’re really helping and it’s really appreciated!

we’re not all from usa you know…
and I don’t understand what’s the point of this comment on this thread?!
and no need to be rude with everybody in all you comments c cchan… thx