How do I make the Hipen H6 work?

Hi, I got my Chuwi UBook Pro yesterday. It came with the Hipen H3 and I also bought the H6.
The H3 was working right from the start, only the buttons didn’t work.
The H6 does not work at all, but I tested it with a Microsoft Surface where it worked except for the Buttons.
On my UBook it shows no sign of working.
What do I have to do to make it work and how do I activate the buttons? Do I need a driver? If yes, where do I get it and how can I install it.

Thanks in advance!

Try the driver update mentioned in this topic.

Thank you for the answer.
I already tried it and it didn’t work. There was always an error when I tried to install the driver update. Later I can send a Screenshot of it, if it helps.

When you update the driver, make sure the pen tip is close (or touching) the screen. It needs to sense the pen in order to update correctly.

Can you send a screenshot of all the HID (Human Interface Devices) listed in your Device Manager?

Sorry answering took me so long, I had a hard day at work.

I tried installing the driver update again with the pen touching the monitor (I started it as an administrator), but it failed again (see first screenshot)

The second pictue is of all he HID in my Device Manager.

The third picture is the error when I try to insall the Goodix Touch Driver

It’s all in German, I’m sorry, I hope it’s okay.


You appear to be missing the I2C HID Device. You need to install the hidi2c.inf file. You might want to search for this driver in the C:\windows\inf folder.

If you don’t have this you could try installing one of the Goodix Touch drivers listed in the Microsoft Update catalog.

https://www.catalog.update.microsoft.com/Search.aspx?q=Goodix%20Touch%20HID

The other place I found a Goodix Touch driver is on this Lenovo site.

https://support.lenovo.com/th/en/downloads/ds112809

Just curious, have you tried to update the Goodix Touch driver inside of Device manager by right clicking and update and search automatically?

1 Like

I fount the hihi2c.inf file, did a right click with the mouse and clicked on install. But still the I2C HID device didn’t appear in the Device Manager… Did I do something wrong?
I also downloaded the newest GoodixTouchDrivers from the Microsoft catalog.
Do I just have to put the files in the C:\windows\inf folder or do I have to install them in some way?
I saw, that my user doesn’t have the authorizations to put something in the C:\windows\inf folder. I have to change that too, I’ll try it when I’m home.

And yes, I’ve tried to automatically search for an update in the Device Manager, but it said that I have the newest version.

No, it should have worked to install from the .inf file that way. You could try to update Goodix Touch in Device Manager and manually point to the hidi2c.inf file.

I assume you got a .cab file from Microsoft. There are a couple of ways to install that. One way is to extract the files using 7-zip into folder and install the .inf file that appears.

Otherwise you should be able to find instructions on the Internet. Here is one web site that explains the procedure.

Lastly, you might want to go under the View menu and click the “Show hidden devices” option and see if that driver is being hidden for some reason.

1 Like

Okay, so I’ve tried to install the .cab in any way you told me and it always says that the driver is already the newest version. I also tried the one from lenovo.
The I2C driver does not seem to be hidden. I also tried to direct the device manager directly to this file.
It seems like nothing has changed.

Okay, another thing to try is to delete the GoodixTouchDriver Device from the Device Manager and reboot the tablet. It will reinstall the touch driver upon restart.

Maybe you have some system file corruption, to check for this do the following:

First run in an Admin Powershell:
DISM.exe /Online /Cleanup-image /Restorehealth

Then run in an Admin Powershell:
sfc /scannow

So this is what it said after I typed in those commands:


It seems, that there have been 87 errors?
It also seems that the option “online/cleanup-image/restorehealth” was not known.

The sfc/scannow command found some corrupted files and fixed those.

I deleted the Goodix Touch Device and now my whole Tocuhscreen doesn’t work…
I already tried to Install it Back with the drivers I Downloaded before, but the Touchscreen Still doesn’t Work. :frowning:

For the “DISM.exe /Online /Cleanup-image /Restorehealth” command, you are missing the space before the “/” character. Please make sure when you type the command it has a space before each “/” character.

Please try this command again with the spaces.

DISM.exe /Online /Cleanup-image /Restorehealth

I just saw this link for the touch drivers that you might want to try if the above still doesn’t work for you.

https://www.drvhub.net/devices/input-devices/goodix/touch-hid

Okay, the Touch works now again but the touch is rotated 90 degrees.
What I mean is, that if I touch the upper part of my screen, the “Touch-symbol” appears on the right of the screen and when I touch on the right of the screen it appears in the lower part.
How can I make it response the right way again?
Calibrating it does not work.

Huh, that is interesting. I haven’t heard of that issue before.

Have you tried to go into Control Panel, Tablet PC settings, first click on setup and run through it for both touch and pen. Then Reset under Display Options, then try to calibrate again.

Also, if you try to go into tablet mode (remove the keyboard) and rotate the screen, does the 90 degree offset still happen in all rotation modes?

Is the HiPen H6 now working for you?

No, that did not work, the touch is still rotated…

If I go into tablet mode, the rotation rotates with the screen, so it’s still 90 degrees of.

And the H6 still does not work. The H3 does work , but the buttons on it still do not work.

Have you ever downloaded the 8100Y TP驱动操作指引new.zip file?

If so, you can try to run the calibration tool that is in the 8100Y TP驱动操作指引new folder. But first you should remove all the chinese characters from the folder name in case that is an issue. Just rename the folder to 8100YTP.

Find the 操作指引.pptx powerpoint presentation and follow it on how to calibrate the touchscreen. Note one change to that powerpoint, the last direction is to click “Send CFG”, before that, you should click “Read CFG”.

If you need that driver, try this link:
http://www.mediafire.com/file/y8tbz11ywe7g7ob/8100Y_TP%E9%A9%B1%E5%8A%A8%E6%93%8D%E4%BD%9C%E6%8C%87%E5%BC%95new.zip/file

I’ve tried that with the N4100 TP zip File because I have the N4100 processor. It didn’t work.
I also tried the 8100Y TP zip File. Didn’t work too.

Well, I am out of ideas on how to fix it without a full restore of Windows.

At this point, I would recommend performing a complete reset of your tablet. Just make sure you save any files that you need onto a flash drive or SD card. You should save any drivers that you downloaded as well.

To do a reset, go into Settings, Update and Security, Recovery and Reset this PC.

Recovery didn’t work… The touch was still wrong…
I’ve sent the UBook Back and bought a new one.
Hopefully the next one won’t have this Problem.

But thank you for your help, you had a lot of good Ideas.

1 Like

Sorry for all your issues. Seems like you had a bad tablet. It is probably for the best to return and get a new one.

Hope all goes well with your new tablet.