LapBook 12.3 Battery

My Lapbook (bought December 2018 on had about 4 hours of battery life for my usage which dropped to about one hour all of a sudden, Osiris Battery Bar Shows wear Level of 0% but battery drain of up to 50000(!)mWh instead of the usual 4000 to 5000.

I tried

  • reinstalling from original emmc Image with and without updates.
  • installing newest Windows 10 build with and without drivers,
  • Linut Mint (Ubuntu based) - it didn’t change.

I tried to contact Chuwi support via e-mail, no reply.

I bought a third party replacement battery from AliExpress (marked as Sony cells, weight slightly higher than original) - no change.

Any ideas what the problem could be?

Have you replaced battery controller from the old battery?
The problem may be in battery controller, charge IC, EC firmware.

I think so, I only kept the frame from the old battery. This is what I bought.

So, you replaced this controller form the old battery?

If yes, try to reinstall battery management driver


no, the new battery came with a new controller and connector, I just plugged it in.

Most likely the problem is in the battery or controller. If you do not have tools for measuring voltage and soldering, then you can not find the problem.

I didn´t use the old controller.
so you think I have two batteries with broken controllers? doesn´t sound
convincing to me, or is a part of the mainboard broken?
To clarify, I already posted a photo of the battery I bought, and this photo shows what i removed form the computer.

I have several soldering irons and a simple multimeter.

I think you need to solder the old controller to a new battery, because new controller looks very bad.
Well, with a multimeter you can check if there is a problem with the battery or lapbook :man_shrugging:

Thank you for your help, I will try this

ok, seems to help, no discharge rate of ~5000mWh - thanks again
Just disappointing that the original battery died after just one year of very light use