Legacy mode not working (Hi 10 X)

For my convenience, I need to put the my tablet in legacy mode.
I just switched boot mode to Legacy, but its not working for some reason.

How can i put my tablet in to legacy mode?

You must disable secure boot.

Yes, I disabled secure boot and its still not working.

What are you traying to boot in legacy?

EasyBCD cannot use some functions unless it is legacy.
I tried rEFInd but touch function are not working. (I enabled touch in config)

I want to setup EFI boot manager that does not use keyboard / mouse

the touch in rEFInd is not working because the driver (goodix) is not on this ISO. Anyway, i think your problem is on BIOS setup, the only thing you need is to activate USB keyboard support in the BIOS setup.

I dont have keyboard for my tablet, I only just want to dual boot without using keyboard and mouse
Also, USB support is turned on in default
EDIT: I found guy that have same problem

Anyway, I found way to access another os using USB.

For multibooting peoples:

Installing (One time)

  1. Install linux on vm
  2. Plug in USB stick and redirect to VM.
  3. Install grub to USB stick. GitHub - ndeineko/grub2-bios-uefi-usb: Create a usb boot drive with support for legacy BIOS and 32/64bit UEFI in a single partition on Linux
  4. Edit grub.cfg to
set timeout=0
menuentry 'Boot'{
    (Boot code here)
  1. Eject USB stick.

How to boot:

  1. Plug in USB stick to Hi10X
  2. Restart windows
  3. Open settings and navigate to Update and Security → Recovery (or run command shutdown /r /o /t 0)
  4. Navigate to Use a device, Select UEFI: Removeable device
  5. Tablet should reboot, and start grub installed on USB stick.

Maybe you can make batch file that do 1~3

(UPDATE) I found that WinRE can select device to boot. process changed little bit.