Problem update UBook Pro to Windows 10 1909

I’m having trouble upgrading Windows 10 to version 1909.
After the download, an installation starts, which reaches 20% freezes and does not move for about an hour.
Any idea where the problem lies.

I had no problem to Update.
Have you installed an external Antivirus ?

No. I just receive tablet.

I also tried Insider Preview. It downloaded, started installing, reached 73% and froze again. Neither Windows 10 1909 nor Insider Preview has an update installed. Where is the problem? I don’t understand why the update is not installed. It is not normal.

I found the following to try:

Go to: C:\ProgramData\Microsoft\Diagnosis
And delete the file called: events_normal.rbs

Then try the update again.

I also read that right now Microsoft servers are overwhelmed so expect updates to hang.

Another way to try to fix this is to navigate to C:\windows and delete SoftwareDistribution folder. It will recreate upon update.

I don’t have a file with that name in this folder. Other ideas.

Update to Windows 10 Insider Preview is OK.

Ciao nickfoxx
Visita il Post
Come aggiornare Windows del tuo Tablet CHUWI alla Versione 1903/1909

Allo stesso Modo puoi aggiornarlo a Windows 10 2004-19041.207.
Visita il Post
Tablet-CHUWI-Hi8 Pro Dual OS (Android 5.1+Windows 10) 32GB si aggiorna alla Versione 2004 19041

Saluti Sabino

Hi Sabino1943,
Thank you very much, but I was able to upgrade Windows 10 Home 1903 to Windows 10 Insider Preview Build 19608.
However, I have been involved in computers and information technology for 20 years. I’m a system administrator, as well as a web designer. This, is my web media.

I had similar problem, but I forced the computer to Shut down/ restart by long pressing power button. When the system loaded, it showed “update failed” and then “search for updates” again and this time i download everything (but it was at 20% for quite long time, half an hour or even more…)

Exactly, but it is not a problem, it seems that during the updates it has stopped because the% does not progress, being anchored in a figure, but if you put the charger and let the process finish, the% advances suddenly and ends successfully

I ran the windows 10 update tool (search for it) last night and let the tablet run all night (it took over 1 hour to get to 20%) but in the morning the update was installed.

I have approximately 200 MBPS internet, so I guess the solution is just to not give up.

Updated to Windows 10 Insider Preview Build 19608 and litle update Windows Next, and work at this time fine.