[SOLVED] Touchpad stops working

Hello!

I´ve had the Aerobook for 5 days now, and twice I had a problem with the touchpad (mouse). it stopped worked all of a sudden. the first time I did not do anything and it got fixed after I restarted the computer later on that day.
but today it happened again, and it does not seem to work properly. The gestures do not work (2 fingers to scroll, etc.) and the pointer does not move as it should, sometime it barely moves.

I tried updating the drivers but it did not work.

does anyone know or can help fixing this issue?

thanks

You must first verify that the system is fully updated. To do this, go to start, configuration, update and security, Windows update.
Check for updates pending installation and perform all processes. Once updated check if you still have the same problems and comment here if yes.
I await your news

Thanks for your reply.
Windows is up to date, and all the drivers are too.
in device manager the touchpad is showing up and everything seems to be ok, according to windows.

not sure what I should do next?

It is very strange what you say, I have the AeroBook and the touchpad works very fine with all Windows gestures, and also with the possibility of canceling its use with the combination of Fn and Esc keys. Make sure you are not pressing these keys by mistake , deactivating the touchpad.

To rule out a software failure, my advice is to perform a Windows restore from the menu options: start, configuration, update and security, recovery, reset this PC, keeping or not keeping your files when asked. A process will begin that you should let it finish without interrupting it, putting the charger. Even if it appears to be stopped and the progress bar does not advance, do not stop or turn it off.
When finished, perform the checks again and see if the fault is repeated.

Thanks a lot for your time and help.

It did not work, unfortunately. I reset windows as you recommended, and after a while when windows started, i tried the touchpad again and nothing has changed, it only moves half way and stops, the right button does not respond and the right one only from time to time.

After the reset I also installed windows updates that were waiting, and after restart nothing changed.
In touchpad settings I changed the sensitivity and speed of pointer and nothing. In this section when I disable touchpad via the settings or with FN+ESC it really stops responding.

I’m starting to think that it’s maybe a hardware failure, because the touchpad only worked for 3days, so i’m contacting thr seller to return the device if I cant fix it.

Yes, everything seems to indicate that it is a hardware failure, so you should contact the seller to get a refund or exchange

Thanks for your support.

can you just check for me what driver version you are running?
mine is Mouse HID 10.0.18362.1

https://1drv.ms/u/s!AqpKvT8-VB_87laOWJamUegU43oi?e=EyCv2T

Here my AeroBook drivers.

@manonegra222 guess what?
I works now, all of a sudden!

I reset the computer completely with MS media creation tool and reset windows completly. that did not fix it neither, but the pointer was moving a little better than before, no gestures still.
I don’t know what I did, but I restarted the computer in recovery mode disabling driver signature. I installed the mouse driver in your files, it did not work so i considered flashing the firmware.
I did not flash anything, but the computer restarted alone at some point and the touchpad started working again…gestures and all.
let’s see how long it will last this time XD.

thanks again for your help, I really appriciate it :slight_smile:

1 Like

Thank you very much for sharing your experience. We will be here to try to help you.