Ubook Keyboard drivers - Error in updated drivers from Indiegogo

After trying to set up the drivers following the link on Indiegogo (Jan, 9, 2020), one of the three .exe programas did not work.
As result of that the touchpad doesn’t work.

Images of the error setting up the drivers:

You can try the following steps. Please read through them first.

  1. Make sure you have no other USB or bluetooth input device connected to the Ubook (mouse or otherwise).
  2. Delete the current mouse and touchpad drivers in Device Manager.
    a) Under Human Interface Devices, delete HID-compliant touch pad (if there) and all USB Input Device (should be 2).
    b) Under Mice and other pointing devices delete any device listed there (should just be one HID-compliant mouse)
  3. Restart the UBook leaving the keyboard attached (if you lost keyboard input use the touchscreen to restart). The touchpad drivers should reload.
  4. Remove all the Chinese characters from the UBook Pro update folder by renaming the folder and deleting the chinese characters. Make sure there are no Chinese characters anywhere in the path.
  5. Again, make sure there are no other USB or bluetooth input devices attached.
  6. Run the update steps again making sure that you disconnect and reattach the keyboard between each of the steps. When disconnecting the keyboard, make sure you pause at least 10 seconds before reattaching the keyboard.
  7. Restart the UBook after the final step for the touchpad drivers to properly install.

I hope this helps.

3 Likes

Dear Silurian,

Thanks a lot for your quick repply.
Your advice looks nice in a first view, I will follow and let you know.
Regards,

I also read that if you press “Fn + Esc” before installing the new drivers, this may also help. the “Fn+Esc” combination toggles the Touchpad off and on.

If you are still having touchpad issue, try the “Fn+Esc” key combo and try to reinstall the drivers again (step 6) above.

1 Like

I’m afraid I’ve delete more HID drivers than required, now the keyboard neither works.
Nevertheless, I also removed all the Chinese characters from the Ubook update folder, I repeated the steps to update the three folders:
Folder 1, Start icon no active. No answer
Forder 2, Same than before, after clicking on Start, the message appearing:“Start DownLoading”, but after some seconds, “Enter Progrmamode Fail”
Folder 3, the same behaviour than Folder 1, no answer

Giving I see this is becoming more complex, I’m starting to thing to restart the system from zero, the PC is quite new and I would not loss nothing important. Do you agree?

Strange that the HID keyboard driver didn’t reinstall on reboot. It should have. You can try going into Device Manager, click Action, and then select Scan for Hardware changes. It should pick up the keyboard again.

If that didn’t work. you can try the Troubleshooter in the Update Settings and run the troubleshooter on the keyboard.

Did you try the “Fn+Esc” combo before running the update steps? I would recommend trying that as well.

Otherwise, I believe you should be able to enter recovery mode through the settings menu. In settings, go to the Update & Security menu, Click Recovery, and then the Reset this PC.

2 Likes

I’m starting to be more concerned, I’ve reset the PC from the recovery options. Choosing the hardest reset, deleting files and settings.
At the end the Keyboard is not working. I’ver reboot the PC but no way. Ufff ¡¡¡

Seems to me that the keyboard update caused some strange issue with your keyboard. You will probably need to get with Chuwi support directly on this one as it appears you have tried many times to make it work without success. Maybe they can send you some file to factory reset your keyboard.

All I can think of is to try to update the keyboard again and see if it work this time. Otherwise, send an email to aftersale-service@chuwi.com for support directly from Chuwi.

2 Likes

Dear Mr. Jaworski,
Thank you again for your help and patience. I will follow your advice.

Nice to have met you.

Best regards,

1 Like

When you find a solution to your issue, please post it here to let everyone know how you finally resolved it.

Thanks!

1 Like

I will do. Don’t worry

1 Like

Jajudez,

Can you post a picture of all your HID devices that show up in Device Manager? I would like to compare it with mine (as below). I have an extra mouse and external keyboard setup right now, so I probably have a few more.

1 Like

I will do this evening and let you know. Thanks for be aware.

Dear Silurian,

Thanks a lot for your concern. I´ve tried to reload again the drivers following strictly the instructions provided by our colleague Beep (in this same chat), I´ve also downloaded again the drivers from the link offered by Management in this chat.,

Fortunately, everything has correctly worked and I´m writing this message using the Kb.

Thanks again and sorry for these crazy crossed mails.

2 Likes

Excellent! I am glad to hear that everything worked out for you.

1 Like

my keyboard has save program that the keyboard does not recognize power.
According to the forum, it is thought that the operation of file1 is the cause, but even if I try to advance file2, the download is not successful and cannot proceed.
Let me know if there is a solution.

I tried the following software according to the procedure, but failed to install at the second slide part of the pptx file.
UBook Pro 8100Y Windows: UBook Pro 8100Y TP driver: http://www.mediafire.com/file/y8tbz11ywe7g7ob/8100Y_TP%E9%A9%B1%E5%8A%A8%E6%93%8D%E4%BD%9C%E6%8C%87%E5%BC%95new.zip/file

I initialized my PC and tried to install the UBook Pro 8100Y TP driver again.
However, there was no photo’s file in this zip folder, and the cfg file in the FW folder could not be read.
My procedure is correct, please give me a solution.