Ubook X Touch Windows Drag Not Working (solved)

Hello,
I have a new Ubook X and am having an issue with the screen and dragging with my finger.
The issue is that the drag breaks and begins again but I did not remove my finger from the screen.
If I try to use Windows Explorer and drag a file around the screen to some destination, it will not work well at all. It will stop the drag somewhere before I get to where I want it to go.
This general odd touch sensativity appears elsewhere to, but the drag in Explorer is a good example.
Another is using a browser. If I was on Amazon for example, when I drag the screen up, the Ubook will sometimes turn the drag into a click and open a link.
These two examples work fine if I use the Chuwi stylus.
Also, I had a Hi10 and my finger worked fine as does another Surface Pro I tested.
Last, a friend just purchased this Ubook X too. When I tested his, right out of the box, using my finger did the same thing. Very odd…
PLEASE help since I have no idea why this tablet is doing this.
Thanks,
Scott

Hi Scott,
Reading your post I can think of some easy-to-answer questions to try to narrow down the problem:
Is your friend’s tablet working fine for him, or is he also experiencing the same problem?
Have you tested if your tablet works well with your other fingers, or with the stylus?
Have you tested whether your tablet works well when used by other people?

Hello Hector,
Thank you for your reply.
The other Ubook X is experiencing the same problem.
The stylus on both works fine vs the finger that does not.
Other fingers, example my wife’s smaller fingers, experiences the same problems.
Yes, the tablets (both Mine and my friends) were tested by all of us (Me, Wife and Friend on both) and experienced the same problem.
If you have any suggestions on how to fix, I’m very interested.
Thanks,
Scott

Hi Scott,
The information you have provided is interesting. Since both tablets behave in the same way, responding well to the stylus, but poorly to human fingers, I would suggest updating the drivers, unless another forum user has a better idea.
In any case, as these are new tablets under warranty, you may want to contact Chuwi technical service (or the merchant where the tablets were purchased) for repair or return.
I am a happy user of my second UBook X and I also used a UBook 10.6 before those two, and I never had such a problem, nor heard of it before reading your post.

Hello Hector,
Again, thank you for your reply.
What drivers? Via Services or Devices? Source?
Also, maybe someone else will have feedback? I too have had another chuwi (Hi10) that worked fine so this is quit odd.
Thanks,
Scott

Hi Scott,
If you do not have experience with Windows settings, I advise you not to touch anything and contact technical service or the seller.
But if you have some experience and are cautious, you can try updating the touch screen driver. Here’s how to do it:
Windows 11 Touchscreen Stops Working in Tablet Mode: Best Fixes - NEXTOFWINDOWS.COM.
So you could see if that solves the problem. In case it does not solve it or another worse problem appears, you could reinstall the original driver.
Yes, other users can read this conversation and perhaps make useful contributions.

Hello Hector,
Thank you for the feedback.
I have already attempted (edit - did successfully) to uninstall/reinstall the 'HD-compliant touch screen driver. A few times actually.
If you have a source for the driver other than what is on the system, I’d be interested/happy to try installing another.
I don’t have any source (say a source from Chuwi- driver disc, etc), so I can’t address the ‘reinstall the original driver’ unless you meant from MS - which has been attempted.
Any other source and/or possible solutions - I am keenly interested…
Thanks,
Scott

Hi Scott,
If you have done these tests and they have not worked, my advice is not to waste any more time and contact the official technical service (service@chuwi.com) or the seller, for help, repair or return. When you contact them, be sure to provide all relevant information (device model, serial number, place and date of purchase, invoice, detailed description and video of the problem, etc.). I hope everything gets solved soon.

Hi Scott, have you tried connecting a mouse to your device to see if it works that way, if the same problem happens then as others mentioned you might have to send it back. If you try Drivereasy on the web it might help also re the drivers.

Hello Todd56,
I attached an external mouse and it works fine. I can drag an object around in Explorer w/o the drag operation being disrupted. Also, the onscreen trackpad (when pressing the left button with one finger and dragging with another finger very absolutely) works fine too.
The issue really seems to be the digitizer resolution and the possible size change of the area of a finger touching the screen changing over time - i.e. the area of the screen being touched during a drag changing due to the finger shape changing over the drag.
Regarding using a 3rd party for drivers seems odd. Chuwi should have any needed drivers made available (don’t think any exist) if the OS does not have them.
Any additional thoughts/test, I’m very interested.

p.s. Thx again Hector and I have reached out to Chuwi w/o response (which seems to be normal?) so I don’t think that is going to present a resolution…

Thanks,
Scott

Hi Scott,
I had to request service assistance from Chuwi two or three times, and I can say that they did not respond immediately, but they did respond within a day or two. Therefore, I am sure that they will accommodate your request. If they don’t, you can ask the supplier to accept the return of the tablet for a refund.
And until their response arrives, you can use the tablet with the mouse or the stylus.

Hello Hector,
I am putting all fingers in the fire so to speak… I am keeping all paths in process to hopefully reach a solution before I have to return due to window of original purchase.
I do hope that Chuwi responds as the Manufacturer.
Maybe they could even respond here.
Thanks again,
Scott

Hi Scott,
Have you tried this?

Hello Hector,
Thanks, I did not know about that opportunity. I grabbed the OS and Driver sources after providing my serial number. The Driver set had the ‘Human Interface Devices’ drivers and I let Windows use that location and it said what it had was best. But, I forced an install from that location and found no change.
The OS image may be attempted but I don’t believe that will produce a different result.
Thanks for the OS and Driver source link!
Scott

1 Like

@smachado Is your serial number ending on this one? xxxxx231002765. Because my colleagues told me they received a similar case, and they provided some drivers, so im not sure if it was your or not.
If it was not you and your serial numbers are between these ones:

image

Download these files:

They said after downloading unzip it to the desktop, double-click to run “update cfg-V160.bat” and try restarting.

If that does not work, tell me:

Or if anyone has any other idea can also participate :slight_smile:

Hello,
Thank you for your reply!
Yes, that is my serial and I did apply that update. The results were mixed. There was an improvement of the finger drag breaking issue. For example, when drawing a line in MS Paint with a slow speed, it did not break when drawing multiple lines. If attempting the same action at a faster pace (certainly within normal usage) it would break as it did before the update.
But, there was a real problem after the driver update, the Stylus now does not work at all. Before the update, it worked correctly with no breaks in drag operations.
I have sent this latest information back and hope that a complete fix will be available soon since I am almost out of time to return it with Amazon.
Here are some videos I made available for review:
First Set - Original issue shown and compared with my Surface Pro 7:

Second Set - after applying the update:

If you have any other feedback or options (or anyone else), I’m very interested in hearing them.
Thanks,
Scott

I will ask on Monday
maybe @manonegra222 can give another suggestion on this weird case :wink:

My colleagues told me you sent them a video. They sent it to tech people to see how to help :slight_smile:

Hello,
Thank you for the reply.
Here is an update for anyone reading this…
I received a second update:
1st:
https://www.mediafire.com/file_premium/nl8i2uf6vqfj6lw/SF121-Phoenix-hid-update-V160%25E8%25A7%25A3%25E5%2586%25B3%25E6%2589%258B%25E8%25A7%25A6%25E6%2596%25AD%25E8%25BF%259E%25E9%2597%25AE%25E9%25A2%2598.zip/file
2nd:

The second seems to have been successful in fixing the drag issue. It also returned the stylus to normal operation (which the 1st update broke).
I am going to try to get testing in before my Amazon window return ends - which is just in a day…
It does seem like the drag issue can be managed by update(s) from Chewi.
Maybe this can be helpful to others who may be encountering similar operation of the touch function(s).
Thanks,
Scott

Thank you for telling us. I will tell my collagues so in case another situation happens they will know what to do :slight_smile: