Windows 10 audio driver for CHUWI CWI535

Hello,

I am going mad trying to get the sound work on a CHUWI CWI535 LapBook. I have just clean installed Windows 10 Home and everything went ok but the audio sound driver is missing. There is an exclamation sign on the audio driver. Where can I get the Windows 10 audio driver for this model?

The easiest for all of us would be to have an official web page with the drivers of every model of CHUWI laptop, and not having to ask here for a driver.

Thank you.

Kind regards.

Thank you so much, Biosham, for your quick answer. But I’ve tried to install your sound drivers, but I still have the same issue. I’ve tried everything even installing them as unsigned drivers, (F7, etc).

When booting the laptop with Linux Mint I can check that the audio sound card is working, so it is a Windows driver only problem.

Accordind to Linux it is an Intel sound card: “Intel Corporation Celeron N3350/Pentium n4200/Atom E3900 Series Audio Cluster (Rev 0b)”.

I’m really desperate, I’ve installed thousands of Windows systems on laptops, but I’ve never seen anything like this.

The laptop is a CHUWI LapBook CWI535.

any help will be appreciated.

Thank you,

[SOLVED]!!!

For anyone with this problem download these drivers:


https://1drv.ms/u/s!AqpKvT8-VB_81UUwDg9yRNNO7KGP?e=Te7PCc

Reboot your Windows (I’ve installed 2020 May Update, 2004) for unsigned driver installation and go to the device manager right clicking on the audio device (with an exclamation mark triangle), go to properties and update the driver searching on the previous downloaded and unzipped file (drivers all lapbook 12,3.zip).

It is important to search on the whole file checking the option to search in subfolders. The driver will install, but two new unknown devices will appear. Do a new search on the same file for the new devices and after rebooting your system, voila! everything is fine now!