Add SSD to Chuwi Larkbox - Windows 10 licence and Boot Order

Dear friends,
I’d like to replace the internal emmc with an SSD and:

  • migrate the windows 10 licence to it
  • set the Larkbox to boot from the SSD

Can you help me out?
Thank you very much, loving this Larkbox SFF!


I want to do exactly the same. What I have done so far:

  1. Install Transcend 430S 512GB (SATA, not NVMe) in M.2 slot
  2. Install the Transcend SSDscope app
  3. Initialize and format the SSD to NFTS
  4. Clone the eMMC drive with the Windows OS to the new drive using the SSDscope app
  5. Resized the drive with Windows on it (using Windows Partition Manager)
  6. Allocate 300 Gb to new drive for data storage on M.2
  7. Enter the BIOS at startup and changed the Boot sequence to boot from Transcend SSD first

I had expected that the Larkbox would now boot from the SSD, but this does not happen. It still boots from the old eMMC drive.

What have I missed or done wrong?

I added a brand new 1TB M.2 and install a brand new Windows on it…

  1. Larkbox doesn’t boot from SSD (D:)
  2. LarkBox doesn’t boot from eMMC (C:)
    to make it short, DOESN’T BOOT at all!
    So, somehow, you’re happy guys :upside_down_face:

How can it be? That’s very weird…

Who knows? That’s very …embarrassing and disappointing, indeed!

According to the instructions in the SSDscope app I have to remove the old disk. I don’t think that’s physically possible and given Alain’s experience I don’t dare to remove the disk with disk management either.

It would be nice if an expert from Chuwi could give us a clue.

1 Like

You can install a “second” Windows on the second SSD drive; you’ll have a second entry in the BootManager, that you can rename later… And you can delete the ‘old’ Windows on ‘C:’ afterward too…
or you can simply keep both Windows (and choose at startup if needed); You 'll have all drivers available on the ‘first’ Windows too.

Does it mean that you managed to fix your problem? How’s that any different than when it wouldn’t boot up at all anymore? Thank you

No, not at all!

  • Windows didn’t boot when unboxing my device
  • so I installed an SSD and a new Windows on it
    -> didn’t boot either from SSD.
    So, it’s still a(nice and small) brick…

If it didn’t boot at all even before adding the ssd, I’d guess that your unit is defective.

Yes, I’m afraid of… To be precise, I have the “chuwi” boot screen and the spinning wheel…but nothing after but a black screen.

Perhaps the steps in this post will help us through:

It’s about a Chuwi laptop with eMMC. Should work the same for Larkbox.

@Alain: it will propably not help with your problem.

1 Like

Thanks for the link to TechTablets @agaudi :wink:
Indeed, I already know this method, I did it in the past on my LapBook SE…
But, you’re right, it won’t probably solve my problem with LarkBox! I’ve updated my prior message… :thinking:

I cannot get it to work. Step 9 does not seem to match Windows 10. The post is from 2017.

Maybe when the SSD versions start arriving, people can share info on what their EMMC partition, bios and boot sequence looks like.

I know back in the day I had a RAID setup to boot Windows, where I had to load some special drivers. It needed to boot from another drive to get Windows to a point that it would see the RAID to get it to finish booting from the RAID.

Why don’t you install a ‘fresh’ Windows on your SSD? That’s what I successfully did. You will have ‘unknown devices’ in Devices Manager but you’ll be able to ‘update driver’ using the files in your old eMMC/Windows/System32.
It’s working for me so far.
No worry about Windows license.

I have tried installing a fresh Windows OS, but it is wetten to the eMMC. Hoe do I het is to go to the SSD?

  1. create a bootable installation USB dongle using Windows Media Creation tool (from Microsoft site)
    2)plug it and boot
  2. follow instructions to install to the SSD (not to the eMMC) -> you’ll need to format it
    4)remove USB dongle before the next reboot
    5)setup your new Windows

Thanks @Alain, this works. I had tried something similar using an SD card. The SSD partition was not visible then. Probably because I did not scroll down far enough.

Using your solution, I made sure I checked for the correct partition. That worked.

1 Like

Great :wink: Glad you can finally use this device. Unfortunately, there are a lot of people complaining/stuck on Indiegogo’s page :frowning: Let’s hope they will find the way to this forum.
(BTW, there is a Discord forum too. Check the Comments on Indiegogo)