I also need a way to reset BIOS settings to factory defaults

Hi there. Sorry to post on the Hi10 X area, but on CHUWI Hi10 Go nuevo 2 en 1 que estrena el nuevo Intel Celeron N5100 I knew it almost the same but processor.
As there is no Hi10 Go area, I decided post here.

I order this product on february 11 2022. Order #13058.

On the site auction they claims 12 days delivery to global address.

I ask for information on chat, february 27, remembering them about 12 days.

They just reply they sent me an email on february 14.

Actually, they sent me an email on february 13 offering an opportunity to change the declared value from $112 to a greater value, but it was not clear they want me a reply, so on march 11, I replied addressing those value questions. I agreed with the $112 value.

But they just fulfilled the order at march 15, under FSC #8993423762 tracking number.

On March 21, I emailed them about DHL over taxing my purchase due to shipment value misinformation. I asked DHL to correct it but didn’t have a solution. So I paid the over rated customs tax.

I received the product just on march 22, almost 1,5 month after ordering it. It´s a chuwi Hi 10 Go tablet model CWI513. Serial # EW1H2111xxxxx

But I’ve been in trouble since then. It doesn’t turn on.

I follow the procedure described in the manual but it doesn’t turn on.

I went to faq and double check the first three instructions present on FAQ-Chuwi - Chuwi Official -Laptop, Android/Windows Tablet PC,Mini PC.

Here, I recorded in a few seconds, what is happening to tablet: https://youtube.com/playlist?list=PLo_JWY9klmG8yqVnTXl_vMqFVNBADvp5D

I immediately contacted [service@chuwi.com] and they promptly offered me a DHL return shipping label in the same week but I consider my skills enough to perform some procedure to try to wake up the HW.

At the time, I was hoping to not have to exchange my Hi 10 Go. I already liked it a lot.

So, after Chuwi´s authorization, I tried the procedure present on Hi10 Go drivers - #15 by parphane. It seems just to restored the OS and didn´t update the bios.

O looked desperately on Chuwi´s forum for the right procedure to update the bios and the correct bios file. I also ask for help on the store@chuwi.com.

On march 26, one week after receiving the product, and under the same dead screen, I asked them by the DHL return shipping label and RMA (Return Merchandize Authorization) and they “promptly” reply after three emails and three days which I have to provide my CPF number. It’s funny, because they had to have the same information when sent the product to me, so they have my CPF. On the following day, I sent the requested CPF number and asked again for RMA (return merchandise authorization). On the same day service@chuwi.com until that moment, away from the situation, asked me: Hello, is the machine can not be turned on now? thanks, and I explained the situation again and asked for some help. They just told me to exchange the machine. And I promptly agreed.

But, not funny enough for them, at march 31, they present me with the following information:

Sorry, we are unable to make return shipments from Brazil due to some unknown errors.

Please you could return the item by yourself.

Please note that you can only use DHL, UPS, TNT, FEDEX or S.F. Express.

My note: those are the most expensive shiping companies I know.

Imediatelly, I asked DHL for the budget to send the package to HK. It would cost me US$170. It´s 2/3 of the value I paid for the product. Among those companies the smallest budget was U$101,05.

Till now it cost me U$552 and they want me to pay more U$101,05 to send it back?

Will I spend U$651,05 to maybe one day receive an U$260 poor quality tablet?

Here, other shipment companies ask U$50 to send it back. But to perform the shipment I must have the RMA anyway. But they don´t provide it yet.

After all this annoyng situation. Frustrated, I had to try one more time to wake up the machine. So on april 3 I email service@chuwi.com, telling the sad history again, informing the SN#, model, etc, and asking for the bios file. Promptly, they reply: Hello, our technology and warehouse have been closed, please contact us after April 6th, thank you.

At april 6th, I ask again, telling all the history again and including store@chuwi.com and aftersale-service@chuwi.com to destination address. So they promptly replyied asking me the serial number and model. On the next day I remembered them I already provide those information on april 3rd email and write it again. They promptly reply: Hello, after I went to check, there is no bios for the time being.

That’s why I’m asking for help on all the forums, chats, and emails I can.
I need to try something to recover this tablet from black screen. Please, help.

  1. Connect power to the top USB-C connector
  2. Press and hold the power button for 15 seconds
  3. Press and hold the power button for 4 seconds

You should either get a Chuwi logo, or a bios notice

I had to buy a usb-C male adapter to usb-A female (ebay, $2), and use a usb keyboard, to access the bios. You could also use a USB C Hub Type C Adapter 4K HDMI USB 3.0 adapter, to use a 2nd hdmi monitor as well as usb 3.0. It is $20 on ebay.

It took me 2 days to get used to the power button. Once working, I had to use windows powerconfig to set the “sleep button” to “turn off display” instead of “sleep”, as I find no way to wake this tablet from windows sleep.


Thank you, Will.
I’m pretty sure already tried those steps, but I’ll repeat it again to double check, following your instructions. Some tip regarding leds?
At moment, I’m trying the force bios reset by discharging battery until depleted. The procedure is described on How to reset bios? Black screen - #10 by DonKing, even being a different equipment I will give it a try.
My Hi10 Go came with keyboard but I’m not able to enter bios setup cause I don’t see anything, the screen is completely off.
I already tried the HDMI adapter to uHDMI, but had no response on the monitor.

The second part of your instructions must the screen working, so I’m not even close to it.

It’s not necessary to say I’m very upsad also.

I suspect the battery is not correctly charging; you should have gotten a red led by now.

Will, I think the charging is ok. I had to buy a spare charger to convince myself it was ok. I bought this one Hi10 Go PD charge - #10 by FabioRPereira. The red led turns on when I plug the original or the spare charger. It stays on until battery complete the charging. It takes near two hours charging. My doubth is about the blue led beside the red one. How does it must behave during the bios reset?
Step 0: press and hold pwr button during 30s (turn tablet off). The blue led started to blink during last 15s. It blinks 30 times. After that, red led blinks one time.
Step 1: Connect power to the top USB-C connector. The red led turns on.
Step 2: Press and hold the power button for 15 seconds. Blue Led turns on till 12th second, after that, it start to blink. When I release the pwr button, blue and red leds turns off.
Step 3: Press and hold the power button for 4 seconds. Tablet and keyboard blue led blinks just one time during pwr press and do not have any led action after that.
I stuck in front of it waiting for an action for 20 minutes.
Thank you again.

Try connecting a usb keyboard, and at 3 seconds, as red led comes on alternate between ESC, Del and other common bios keys - F2, F12

Or have you already tried this?

Yes, I tried this, but have no results(screen continue off).
You told the red led should turns on at 3 seconds but it never happened on the tablet.
I tried also make a full system recovery as stated in Hi10 Go drivers - #17 by iuwu871.
But even if I have success, it would continue black screen cause, as stated in major cases here on forum. the black screen have todo with bios.
Thank you for assistance.