Minibook, No Battery Present

Just picked up a NIB Minibook. Plugged it in, powered up, got it all set up with Windows.

Problem is Windows wont recognize the battery, just says “no battery present”. Battery/charging light just flashes red.

I’ve tried power cycling, unplugging my battery, and updating Windows. I think the OS recognizes the dead battery on startup and boots as if its not there.

Battery driver isn’t present in device manager.

I believe my battery is now completely dead and wont charge.
Any suggestions?

First you should reinstall the driver, but since it is not in the device manager, you should check what Aida64 says about the battery. If there is no battery information too, download the snappy driver installer or any similar programm (don’t update any other drivers, it can “brick” system). If the program detects the battery - try to install the driver, if not - check if the battery itself is connected.

So, I found the driver (it was hidden in device manager). Tried deleting it and reinstalling it. Rebooting, no luck.

Also tried the driver installer, no luck.

Picture of my battery.

Picture of my startup screen. This comes up then it flashes into a normal boot screen.

Looks like hardware problem, try write to aftersale@chuwi.com .

Hello,

I have the same error.
My Battery ist not showing in Windows and I can’t charge it.
But Driver and Information are showing on Aida64.

On pluged charger no LED turn on…
what can I do?

Now the Battery is complete dead an it doesn’t turn on. With pluged charger it doesn’t turn on.

I have read that I can unplug the battery.
Allways it’s works.
Can I do it without lose warranty?

It depends on the civil code and consumer protection of your country, for example, in my country I can open the device and disconnect any FFC without losing the warranty (but if the warranty seal is on FFC - the service center will inspect the board for a long time)

Thank you for Information.

I question.
Can the MiniBook turn on with unplugged battery but plugged charger?

I test it in the evening.
I hope it works… I have the MiniBook 1 week…

I know that some laptops from lenovo and hp with internal battery can’t turn on without it.
Not sure about minibook.

Now it works but only have 11400mwh?

Software never tell truth, so don’t trust these numbers. :slightly_smiling_face:

Haha I have reset it and now all works :joy::+1:
Thanks😊

But I have one question.
I can charge it only with the charger with that come. No power bank works or my other charger for my smartphone. Why?

I don’t have any information about that. Maybe the laptop has an original charger detection system. Also charger and power bank must be approved to switch the voltage from 5V to 12V and I don’t think that this is implemented in a laptop.
I found that this laptop supports “PD2.0 fast charging with any PD adapter
or power bank” , so make sure you are using PD2.0 charger.

I bought a believe bank BASEUS MULIGHT DIGITAL DISPLAY QUICK CHARGE POWER BANK 45W (PPMY-A01) 20000MAH. But his laptop does not detect. There are recommended powerbank?

No worries load with my Xiaomi PowerBank 3, everything works wonderfully

What version of N4100 or Core m3-8100Y do you have? I have a version of N4100. for some reason mine is not charging from powerbank (

I use the m3-8100Y on my MiniBook