Need Help! (with Chuwi Ubook Goodix GT738X)

Does anyone have the cfg file for Ubook 4100 (Non-pro)?? I have accidentally used the TP drivers for Ubook Pro thinking I had a Pro version. I am now having a deadzone and ghost touch. I have tried this fix the ghost touch is gone however the orientation is incorrect.

3 Likes

Hi Rixe, of your problem is only orientation, i can try to make another one for you. The touch is moving to the same side? or have inverted axis? I need:

  • Full resolution of your tablet
  • If you have any problem (apart from screen orientation).
1 Like

Its also inverted, my tablet’s resolution is 1920x1080.
Much thanks!

1 Like

try with this, 335.7 KB file on MEGA
and tell me if after this update, you have any problem. I am going to try to gradually solve the problems for your tablet.

1 Like

Thank you so much! I will send an update once I’ve tried this!

1 Like

Hi the touch is still off here’s a video of a demo

1 Like

Ok, so you have the axis inverted too… wait a second, i will prepare new driver for you.

2 Likes

use this cfg file. Put it into the folder for the upgrade firmware configuration and run it. 2.2 KB file on MEGA

1 Like

OH MY GOD!! ALMOST FIXED IT!! The tracking is just a bit off and there’s a deadzone but this is much better than before!! You sir are amazing! Here’s the vid

1 Like

Perfect, so let me try to fix the deadzones and i will upload new file ASAP. =)

1 Like

Okay! Thank you so much!!

No problem =). Try with this cfg file : 2.2 KB file on MEGA

Rename it to delete the _1 suffix or copy the name in the configUpdate.bat.

Tell me if the situation improves or worsens and we will solve everything.

Tracking is much better now but the deadzone has transferred a bit to the middle. For some reason ghost touches happen when on lockscreen Here’s the vid!

OK, the problem is in sensors config in the firmware… its very difficult to make it without the same tablet in my hands, but i try to configure it. Give me a few menutes please.

2.2 KB file on MEGA this is the new file. Same of the last file, rename it because the suffix. =)

Ghost touch is gone!! Deadzone got a bit bigger tho here’s the vid!

Ok, this is the new file: File on MEGA , in this file, the only change is the memory location for the sensors, maybe nothing changes, but if anything change, we are going in the correct way. Try it and tell me.

You can try this: Phoenix-hid-update-YWHF12003-SG12G-20200811 (mediafire.com) , is the original firmware of your tablet, maybe works

tell me what is the better firmware to update from it if any error remaining.

I tried yours and the one from “Phoenix-hid-update” nothing worked there tho but I think there was something better from it, I used this file, and now I only have 1 horizontal deadzone. Here’s a vid! :smiley: